aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Manison <amanison@byrd-vm.localdomain>2010-04-04 16:51:44 -0400
committerAndrew Manison <amanison@byrd-vm.localdomain>2010-04-04 16:51:44 -0400
commitc9214a0549042005267e97080de0cac812deb8ab (patch)
treefe9ad881f0c93849647ec984a5f920ce45fac594
parent8b35a9ab83a841ab17ead4606f647a3158c274fe (diff)
downloadaports-c9214a0549042005267e97080de0cac812deb8ab.tar.bz2
aports-c9214a0549042005267e97080de0cac812deb8ab.tar.xz
Changes to package builds to fix missing/changed/broken source archives.
-rw-r--r--Makefile33
-rw-r--r--main/cramfs/APKBUILD4
-rw-r--r--main/curl/APKBUILD6
-rw-r--r--main/dhcp/APKBUILD2
-rw-r--r--main/dialog/APKBUILD6
-rw-r--r--main/procps/01-fix-install-options-for-busybox.patch65
-rw-r--r--main/procps/APKBUILD13
7 files changed, 94 insertions, 35 deletions
diff --git a/Makefile b/Makefile
index 993cc16a1a..0bfa4e0080 100644
--- a/Makefile
+++ b/Makefile
@@ -4,6 +4,10 @@ rootdir := $(shell pwd)
all: main testing non-free unstable
+apkbuilds := $(shell find . -maxdepth 3 -name APKBUILD -print)
+
+all-modules := $(sort $(subst ./,,$(patsubst %/,%,$(dir $(apkbuilds)))))
+
main-modules := $(sort \
$(notdir \
$(patsubst %/,%, \
@@ -57,33 +61,16 @@ unstable:
done
clean:
- for p in $(main-modules) ; \
- do \
- cd $(rootdir)/main/$$p; \
- abuild clean; \
- abuild cleanoldpkg; \
- abuild cleanpkg; \
- abuild cleancache; \
- done
- for p in $(testing-modules) ; \
- do \
- cd $(rootdir)/testing/$$p; \
+ for p in $(all-modules) ; do \
+ cd $(rootdir)/$$p; \
abuild clean; \
- abuild cleanoldpkg; \
abuild cleanpkg; \
- abuild cleancache; \
done
- for p in $(non-free-modules) ; \
- do \
- cd $(rootdir)/non-free/$$p; \
- abuild clean; \
- abuild cleanoldpkg; \
- abuild cleanpkg; \
- abuild cleancache; \
- done
- for p in $(unstable-modules) ; \
+
+distclean:
+ for p in $(all-modules) ; \
do \
- cd $(rootdir)/unstable/$$p; \
+ cd $(rootdir)/$$p; \
abuild clean; \
abuild cleanoldpkg; \
abuild cleanpkg; \
diff --git a/main/cramfs/APKBUILD b/main/cramfs/APKBUILD
index e40e57c2cc..d552fec3c2 100644
--- a/main/cramfs/APKBUILD
+++ b/main/cramfs/APKBUILD
@@ -1,12 +1,12 @@
# Maintainer: Natanael Copa <natanael.copa@gmail.com>
pkgname=cramfs
pkgver=1.1
-pkgrel=0
+pkgrel=1
pkgdesc="Linux filesystem designed to be simple, small, and to compress things well"
arch=""
url="http://sourceforge.net/projects/cramfs/"
license='GPL'
-depends="uclibc zlib"
+depends=""
makedepends="zlib-dev"
source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz"
diff --git a/main/curl/APKBUILD b/main/curl/APKBUILD
index a7bcbd03ba..fb4ed38d6e 100644
--- a/main/curl/APKBUILD
+++ b/main/curl/APKBUILD
@@ -1,13 +1,13 @@
# Maintainer: Carlo Landmeter <clandmeter at gmail.com>
pkgname=curl
-pkgver=7.19.7
+pkgver=7.20.0
pkgrel=0
pkgdesc="An URL retrival utility and library"
url="http://curl.haxx.se"
license="MIT"
depends=
makedepends="zlib-dev openssl-dev"
-source="http://curl.osmirror.nl/download/curl-$pkgver.tar.bz2"
+source="http://curl.haxx.se/download/curl-$pkgver.tar.bz2"
subpackages="$pkgname-doc $pkgname-dev"
@@ -25,4 +25,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-md5sums="79a8fbb2eed5464b97bdf94bee109380 curl-7.19.7.tar.bz2"
+md5sums="3dda78c4a808d9a779dc3a2ae81b47d8 curl-7.20.0.tar.bz2"
diff --git a/main/dhcp/APKBUILD b/main/dhcp/APKBUILD
index 33f4e85314..ab15af69bd 100644
--- a/main/dhcp/APKBUILD
+++ b/main/dhcp/APKBUILD
@@ -10,7 +10,7 @@ depends=
makedepends=
install="dhcp.pre-install dhcp.post-install dhcp.pre-upgrade dhcp.post-upgrade"
subpackages="$pkgname-doc $pkgname-dev dhclient dhcrelay"
-source="http://ftp.isc.org/isc/dhcp/$pkgname-$_realver.tar.gz
+source="http://ftp.isc.org/isc/dhcp/dhcp-4.1-history/$pkgname-$_realver.tar.gz
linux_ipv6_discover.patch
dhcp-3.0-fix-perms.patch
dhcrelay.initd
diff --git a/main/dialog/APKBUILD b/main/dialog/APKBUILD
index 99619e31cf..a94e4f99dd 100644
--- a/main/dialog/APKBUILD
+++ b/main/dialog/APKBUILD
@@ -1,13 +1,13 @@
# Contributor: Michael Mason <ms13sp@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=dialog
-pkgver=1.1.20080819
+pkgver=1.1.20100119
_ver=${pkgver%.*}-${pkgver##*.}
pkgrel=0
pkgdesc="A script-interpreter which provides a set of curses"
url="http://invisible-island.net/dialog/dialog.html"
license="GPL"
-depends="uclibc ncurses"
+depends=""
makedepends="ncurses-dev"
install=
subpackages="$pkgname-doc"
@@ -24,4 +24,4 @@ build() {
make DESTDIR="$pkgdir" install
}
-md5sums="3caebd641a9f337b980becb4444336c5 dialog.tar.gz"
+md5sums="3d62219658fdddf3c6247fb45831a5d0 dialog.tar.gz"
diff --git a/main/procps/01-fix-install-options-for-busybox.patch b/main/procps/01-fix-install-options-for-busybox.patch
new file mode 100644
index 0000000000..792a78155b
--- /dev/null
+++ b/main/procps/01-fix-install-options-for-busybox.patch
@@ -0,0 +1,65 @@
+--- orig/procps-3.2.8/Makefile
++++ src/procps-3.2.8/Makefile
+@@ -27,7 +27,7 @@
+ ldconfig := ldconfig
+ ln_f := ln -f
+ ln_sf := ln -sf
+-install := install -D --owner 0 --group 0
++install := install -D -o 0 -g 0
+
+ # Lame x86-64 /lib64 and /usr/lib64 abomination:
+ lib64 := lib$(shell [ -d /lib64 ] && echo 64)
+@@ -222,10 +222,10 @@
+ ###### install
+
+ $(BINFILES) : all
+- $(install) --mode a=rx $(notdir $@) $@
++ $(install) -m a=rx $(notdir $@) $@
+
+ $(MANFILES) : all
+- $(install) --mode a=r $(notdir $@) $@
++ $(install) -m a=r $(notdir $@) $@
+
+ install: $(filter-out $(SKIP) $(addprefix $(DESTDIR),$(SKIP)),$(INSTALL))
+ cd $(usr/bin) && $(ln_f) skill snice
+--- orig/procps-3.2.8/proc/module.mk
++++ src/procps-3.2.8/proc/module.mk
+@@ -96,7 +96,7 @@
+ #################### install rules ###########################
+
+ $(lib)$(SOFILE) : proc/$(SONAME)
+- $(install) --mode a=rx $< $@
++ $(install) -m a=rx $< $@
+
+ ifneq ($(SOLINK),$(SOFILE))
+ .PHONY: $(lib)$(SOLINK)
+@@ -115,14 +115,14 @@
+ $(ldconfig)
+
+ $(usr/lib)$(ANAME) : proc/$(ANAME)
+- $(install) --mode a=r $< $@
++ $(install) -m a=r $< $@
+
+ # Junk anyway... supposed to go in /usr/include/$(NAME)
+ #INSTALL += $(addprefix $(include),$(HDRFILES))
+ #
+ #$(addprefix $(include),$(HDRFILES)): $(include)% : proc/%
+ #$(include)% : proc/%
+-# $(install) --mode a=r $< $@
++# $(install) -m a=r $< $@
+
+ ##################################################################
+
+--- orig/procps-3.2.8/ps/module.mk
++++ src/procps-3.2.8/ps/module.mk
+@@ -33,8 +33,8 @@
+
+
+ $(bin)ps: ps/ps
+- $(install) --mode a=rx $< $@
++ $(install) -m a=rx $< $@
+
+ $(man1)ps.1 : ps/ps.1
+- $(install) --mode a=r $< $@
++ $(install) -m a=r $< $@
+ -rm -f $(DESTDIR)/var/catman/cat1/ps.1.gz $(DESTDIR)/var/man/cat1/ps.1.gz
diff --git a/main/procps/APKBUILD b/main/procps/APKBUILD
index 83204ad1b3..f0f169779a 100644
--- a/main/procps/APKBUILD
+++ b/main/procps/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=procps
pkgver=3.2.8
-pkgrel=0
+pkgrel=1
pkgdesc="Utilities for monitoring your system and processes on your system"
url="http://procps.sourceforge.net/"
license="GPL LGPL"
@@ -9,7 +9,13 @@ depends=
# needs fancy install
makedepends="ncurses-dev coreutils"
subpackages="$pkgname-dev $pkgname-doc libproc"
-source="http://$pkgname.sourceforge.net/$pkgname-$pkgver.tar.gz"
+source="http://$pkgname.sourceforge.net/$pkgname-$pkgver.tar.gz
+ 01-fix-install-options-for-busybox.patch"
+
+prepare() {
+ cd "$srcdir"
+ patch -p1 -i "$srcdir"/01-fix-install-options-for-busybox.patch || return 1
+}
build() {
cd "$srcdir"/$pkgname-$pkgver
@@ -30,4 +36,5 @@ libproc() {
ln -s libproc-$pkgver.so "$subpkgdir"/lib/libproc.so
}
-md5sums="9532714b6846013ca9898984ba4cd7e0 procps-3.2.8.tar.gz"
+md5sums="9532714b6846013ca9898984ba4cd7e0 procps-3.2.8.tar.gz
+2b821e841acd08620789d5ffd19d58e9 01-fix-install-options-for-busybox.patch"