aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2016-10-07 07:45:53 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2016-10-10 12:04:33 +0000
commitcc3fa43f44f2f6e9431fb2e5996f72e81b0e6d0a (patch)
tree5afd59534ed40de5c3e19aa42ff96ae8e6ff9c8c
parent9c3faa4defee87750a166f405750e445a7f8ce44 (diff)
downloadaports-cc3fa43f44f2f6e9431fb2e5996f72e81b0e6d0a.tar.bz2
aports-cc3fa43f44f2f6e9431fb2e5996f72e81b0e6d0a.tar.xz
main/xchat: rebuild against libressl
-rw-r--r--main/xchat/APKBUILD19
-rw-r--r--main/xchat/libressl.patch20
2 files changed, 35 insertions, 4 deletions
diff --git a/main/xchat/APKBUILD b/main/xchat/APKBUILD
index fecaeccf3d..094e321636 100644
--- a/main/xchat/APKBUILD
+++ b/main/xchat/APKBUILD
@@ -1,18 +1,19 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=xchat
pkgver=2.8.8
-pkgrel=10
+pkgrel=11
pkgdesc="A GTK+ based IRC client"
url="http://www.xchat.org/"
arch="all"
license="GPL"
subpackages="$pkgname-lang"
-makedepends="gtk+-dev openssl-dev dbus-glib-dev perl-dev
+makedepends="gtk+-dev libressl-dev dbus-glib-dev perl-dev
libxext-dev"
source="http://www.$pkgname.org/files/source/2.8/$pkgname-$pkgver.tar.bz2
midori.patch
xchat-2.8.8-glib-2.31.patch
link-gmodule.patch
+ libressl.patch
"
_builddir="$srcdir"/$pkgname-$pkgver
@@ -35,7 +36,6 @@ build() {
--sysconfdir=/etc \
--enable-openssl \
--enable-dbus \
- --disable-gnome \
--disable-textfe \
--disable-perl \
--disable-python \
@@ -54,4 +54,15 @@ package() {
md5sums="6775c44f38e84d06c06c336b32c4a452 xchat-2.8.8.tar.bz2
759fd786be3a2546be33f7533632b5a2 midori.patch
98f5c7b49a3e0bad4ef0b7871fdcd8b5 xchat-2.8.8-glib-2.31.patch
-6efe686e4747e1ea22c368cf83fb6ea2 link-gmodule.patch"
+6efe686e4747e1ea22c368cf83fb6ea2 link-gmodule.patch
+03d419af35a860e305dc5a80c2f809ba libressl.patch"
+sha256sums="0d6d69437b5e1e45f3e66270fe369344943de8a1190e498fafa5296315a27db0 xchat-2.8.8.tar.bz2
+9a06b649e5ab99428b8e838f8680ad62595c8eb068e37127436eea21998f1af9 midori.patch
+8406db6eb273595b6acb4da0ac4befa684f168e1e5c821d48096d508102d7a66 xchat-2.8.8-glib-2.31.patch
+332b691c69f6e11fb8fd13fa6328b8cebc64e53063923c406dcf590d964bb1cf link-gmodule.patch
+bd16634333265cb4c11dfc43694e9d7f14b669adc10a0fb3adf5421e1c6735f6 libressl.patch"
+sha512sums="70eddc15a8bb08283b94f4d7bb5225016d42dd7bb946ac30f8e53bb68b892d15dd2a77d8825e5872e47b6d55f15ae468db1a7466676cd548d0a05c571d76db2b xchat-2.8.8.tar.bz2
+cff2d877182dc653df6446efe5bd7f7f1365b9b1abaa42c4dc1ab8797ff2366e36878bbc3b3a5e5386da1edfe2339ea304d0b0f55b7ae3bff6120bc39c83dda5 midori.patch
+b22da471b424b5270733f1c676e46ad411a70d0f14cfa1b42abde270f36c7da8afbeca235e0aa3b504ff35c8177012439e02841e6192fb8947cf0f7c0060e1be xchat-2.8.8-glib-2.31.patch
+a67671bfd5afa600c7b19f3bce2ba32913f65f115f0beb9397aef28d9941b88d4a9e6fca12a8c78122a5d8379c614f19f7b9e1f4f4384ed2c94594ce0b6c8ade link-gmodule.patch
+d2dc08e57c1d9da8487fa8f4e62053b3ff13964e0015860b27bde67a2c1af6e6ad5c7fdd374735145d2b5bb26b4e33e518fbc401c940f7110ec97b1558f99e47 libressl.patch"
diff --git a/main/xchat/libressl.patch b/main/xchat/libressl.patch
new file mode 100644
index 0000000000..3a971735dd
--- /dev/null
+++ b/main/xchat/libressl.patch
@@ -0,0 +1,20 @@
+--- a/src/common/ssl.c.orig 2016-03-30 20:54:51.193579450 +0200
++++ b/src/common/ssl.c 2016-03-30 20:55:03.070579987 +0200
+@@ -70,7 +70,7 @@
+
+ SSLeay_add_ssl_algorithms ();
+ SSL_load_error_strings ();
+- ctx = SSL_CTX_new (server ? SSLv3_server_method() : SSLv3_client_method ());
++ ctx = SSL_CTX_new (server ? SSLv23_server_method() : SSLv23_client_method ());
+
+ SSL_CTX_set_session_cache_mode (ctx, SSL_SESS_CACHE_BOTH);
+ SSL_CTX_set_timeout (ctx, 300);
+@@ -281,7 +281,7 @@
+ __SSL_critical_error ("SSL_new");
+
+ SSL_set_fd (ssl, sd);
+- if (ctx->method == SSLv3_client_method())
++ if (ctx->method == SSLv23_client_method())
+ SSL_set_connect_state (ssl);
+ else
+ SSL_set_accept_state(ssl);