aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-05-08 10:09:43 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-05-08 10:09:52 +0000
commitce4cc7988199b1ab25a77ddbc28eeb4e17d59639 (patch)
treeedb8fb78fe76a5353242f38e043c08084e68f4ac
parentae25ce2088e1da7ae404c8d15e48a5a09cf13289 (diff)
downloadaports-ce4cc7988199b1ab25a77ddbc28eeb4e17d59639.tar.bz2
aports-ce4cc7988199b1ab25a77ddbc28eeb4e17d59639.tar.xz
community/quazip: adopt, switch to qt5, upgrade to 0.7.6
-rw-r--r--community/quazip/APKBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/community/quazip/APKBUILD b/community/quazip/APKBUILD
index 9cc48e3080..3adc0b4ffd 100644
--- a/community/quazip/APKBUILD
+++ b/community/quazip/APKBUILD
@@ -1,20 +1,21 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
-# Maintainer:
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=quazip
-pkgver=0.7.3
+pkgver=0.7.6
pkgrel=0
pkgdesc="C++ wrapper for the Gilles Vollant's ZIP/UNZIP C package"
url="https://sourceforge.net/projects/quazip/"
arch="all"
license="LGPL"
-makedepends="qt-dev cmake"
+makedepends="qt5-qtbase-dev cmake"
subpackages="$pkgname-dev"
-source="https://downloads.sourceforge.net/quazip/$pkgname-$pkgver.tar.gz"
+source="quazip-$pkgver.tar.gz::https://github.com/stachenov/quazip/archive/$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgver"
build() {
cd "$builddir"
- qmake PREFIX=/usr
+ qmake-qt5 PREFIX=/usr
+ make
}
package() {
@@ -22,4 +23,4 @@ package() {
make INSTALL_ROOT="$pkgdir" install
}
-sha512sums="d4b55bd040e47e97e7bd5d080399ae4aa5fbc4985d6ab5979b468abc852c91b2e3e5d35af90d4b4de3bb01ea9135d0247473d6eab0413392b1c8567dc799a9fe quazip-0.7.3.tar.gz"
+sha512sums="4325a69918216bb66c6a7c53589ef73473c3752151522a135dd9c92dbf722b29656aea7be0314c84399a214391eca79296ecda5811ab31845d8cf53c010110d1 quazip-0.7.6.tar.gz"