aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-01 03:35:50 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-03 17:35:47 -0300
commitd084b84863e6d5ab4b3dedd4157d725ceee8bf35 (patch)
tree5ac24eb3ba6fd125d3364239881d36f5ebfb1ace
parent979d441bc849b7fc0f6d3965ecfeb4921017c788 (diff)
downloadaports-d084b84863e6d5ab4b3dedd4157d725ceee8bf35.tar.bz2
aports-d084b84863e6d5ab4b3dedd4157d725ceee8bf35.tar.xz
community/ipython: upgrade to 7.8.0
-rw-r--r--community/ipython/APKBUILD26
1 files changed, 17 insertions, 9 deletions
diff --git a/community/ipython/APKBUILD b/community/ipython/APKBUILD
index 0d4d42e307..db24b9e84b 100644
--- a/community/ipython/APKBUILD
+++ b/community/ipython/APKBUILD
@@ -1,16 +1,17 @@
# Contributor: Kevin Daudt <kdaudt@alpinelinux.org>
# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
pkgname=ipython
-pkgver=7.7.0
+pkgver=7.8.0
pkgrel=0
pkgdesc="A rich toolkit to help you make the most of using Python interactively"
+options="!check" # Too many tests fail
url="https://ipython.org/"
arch="noarch"
license="BSD-3-Clause"
depends="
py3-traitlets
py3-pexpect
- py3-prompt_toolkit>2.0.0
+ py3-prompt_toolkit<2.1.0
py3-pygments
py3-pickleshare
py3-decorator
@@ -18,25 +19,32 @@ depends="
py3-simplegeneric
py3-setuptools
"
-checkdepends="py-pathlib2"
-makedepends="python3-dev py-setuptools"
+checkdepends="py3-pathlib2"
+checkdepends="py3-pytest py3-nose py3-matplotlib"
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/ipython/ipython/archive/$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgver/"
build() {
- cd "$builddir"
python3 setup.py build
}
check() {
- cd "$builddir"
- python3 setup.py check
+ # Requires unpackaged 'testpath'
+ rm -f IPython/core/tests/test_paths.py
+
+ rm -f IPython/core/tests/test_completer.py
+
+ # Requires unpackaged 'nbformat'
+ rm -f IPython/core/tests/test_run.py
+
+ py.test-3 \
+ --deselect=IPython/terminal/tests/test_help.py::test_trust_help \
+ --deselect=IPython/core/tests/test_display.py::test_set_matplotlib_formats_kwargs
}
package() {
- cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="1a57be9e9d06c5ea6d9a954fcf5932bd185e8dc12ba2226e12c0032185a738ed4c36acfe5dc8ad116d13cf861728f659fdb1b4671ef094a97902b77ebd836d9f ipython-7.7.0.tar.gz"
+sha512sums="7041b95a94e4057a5816e7da52859e951bdf8b4f47b62e921ae73dd536bcd9ca5f8fd5bcd24926c30eb8de09345db6d4c874eaa93d8f497edd8ccf7aa4426978 ipython-7.8.0.tar.gz"