aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-12-12 04:29:23 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-12-12 15:56:02 +0100
commitd2b8817ad268ec6e0f57acf1c046fd474389521e (patch)
treef91f42869cb33347c8ca8802225ba773fb43bc91
parentcd7e32607b1fb1b46a90905e04924e71bd8b4783 (diff)
downloadaports-d2b8817ad268ec6e0f57acf1c046fd474389521e.tar.bz2
aports-d2b8817ad268ec6e0f57acf1c046fd474389521e.tar.xz
testing/qt-creator: upgrade to 4.11.0
-rw-r--r--testing/qt-creator/APKBUILD6
-rw-r--r--testing/qt-creator/fix-execinfo.patch5
2 files changed, 5 insertions, 6 deletions
diff --git a/testing/qt-creator/APKBUILD b/testing/qt-creator/APKBUILD
index 4f5f32dc84..794d9f3a52 100644
--- a/testing/qt-creator/APKBUILD
+++ b/testing/qt-creator/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=qt-creator
_pkgname=qt-creator-opensource-src
-pkgver=4.10.2
+pkgver=4.11.0
pkgrel=0
pkgdesc="Lightweight and cross-platform IDE for Qt"
url="https://qt-project.org/wiki/Category:Tools::QtCreator"
@@ -44,5 +44,5 @@ package() {
# "$pkgdir"/usr/share/applications/qtcreator.desktop
}
-sha512sums="358bf6e892b70ae9b0bfcd3618d97f0d1880e41f8fc057a20043adc944d7b18d6b7ca7b6908ff8f2c78afc16047b3ff365a9385019a317e69ecf374a70eb8a01 qt-creator-opensource-src-4.10.2.tar.gz
-0f9e03d73d0c25e9251fd1b323ea353c2b6bd50a3a75fae9cfe5e5d1bc0b201aa5735e0cbff02d00d1f84fe3cc3efea76d95da4b7c164d089e5aa8c705321b42 fix-execinfo.patch"
+sha512sums="29e5c72d4002cdddecbdea689dd5048aa8d0b74c980a6b8096b03c3c39f4868e4490c4516ba287a4082eaaa4ec412309c1d498a4f97754720c88ae4ab53d30b8 qt-creator-opensource-src-4.11.0.tar.gz
+416bf589487aa0a86df01cb07088d1bf316bb7b765753b870634be8f697c17a47a93c2240258e8f1707fe8e0137b8cbc1a7b85250986ede3bffb87c6c5f75311 fix-execinfo.patch"
diff --git a/testing/qt-creator/fix-execinfo.patch b/testing/qt-creator/fix-execinfo.patch
index c3828c34b6..750968f75e 100644
--- a/testing/qt-creator/fix-execinfo.patch
+++ b/testing/qt-creator/fix-execinfo.patch
@@ -39,13 +39,12 @@
namespace Debugger {
namespace Internal {
-@@ -45,7 +47,7 @@
+@@ -40,7 +40,7 @@ void dumpBacktrace(int maxdepth)
{
if (maxdepth == -1)
maxdepth = 200;
-#if defined(Q_OS_LINUX)
+#if defined(Q_OS_LINUX) && defined(__GLIBC__)
- void *bt[200] = {0};
+ void *bt[200] = {nullptr};
qDebug() << "BACKTRACE:";
int size = backtrace(bt, sizeof(bt) / sizeof(bt[0]));
-