aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-10-28 12:17:39 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-10-28 12:17:39 +0000
commitd323efec10f851ec0fe993d4ae18f10af98e5840 (patch)
tree0d3416b54fef42d362b6589de2c44933de7f435a
parentc5b7fe019808ce1a437895a65816f8d2b13ec79d (diff)
downloadaports-d323efec10f851ec0fe993d4ae18f10af98e5840.tar.bz2
aports-d323efec10f851ec0fe993d4ae18f10af98e5840.tar.xz
main/gst-plugins-good: build fix with newer kernel headers
-rw-r--r--main/gst-plugins-good/0001-sys-v4l2-Some-blind-compilation-fixes.patch57
-rw-r--r--main/gst-plugins-good/APKBUILD11
-rw-r--r--main/gst-plugins-good/drop-v4l2_buffer-input.patch15
3 files changed, 65 insertions, 18 deletions
diff --git a/main/gst-plugins-good/0001-sys-v4l2-Some-blind-compilation-fixes.patch b/main/gst-plugins-good/0001-sys-v4l2-Some-blind-compilation-fixes.patch
new file mode 100644
index 0000000000..e03fdac894
--- /dev/null
+++ b/main/gst-plugins-good/0001-sys-v4l2-Some-blind-compilation-fixes.patch
@@ -0,0 +1,57 @@
+From fa21c0bb253213c9dc48ce72faaf7090dc8a3554 Mon Sep 17 00:00:00 2001
+From: Colin Walters <walters@verbum.org>
+Date: Thu, 2 May 2013 16:16:46 -0400
+Subject: [PATCH] sys/v4l2: Some blind compilation fixes
+
+---
+ sys/v4l2/gstv4l2bufferpool.c | 1 -
+ sys/v4l2/v4l2_calls.c | 12 ++++--------
+ 2 files changed, 4 insertions(+), 9 deletions(-)
+
+diff --git a/sys/v4l2/gstv4l2bufferpool.c b/sys/v4l2/gstv4l2bufferpool.c
+index a0b4c84..3916815 100644
+--- a/sys/v4l2/gstv4l2bufferpool.c
++++ b/sys/v4l2/gstv4l2bufferpool.c
+@@ -182,7 +182,6 @@ gst_v4l2_buffer_new (GstV4l2BufferPool * pool, guint index, GstCaps * caps)
+ GST_LOG_OBJECT (pool->v4l2elem, " MMAP offset: %u",
+ ret->vbuffer.m.offset);
+ GST_LOG_OBJECT (pool->v4l2elem, " length: %u", ret->vbuffer.length);
+- GST_LOG_OBJECT (pool->v4l2elem, " input: %u", ret->vbuffer.input);
+
+ ret->mmap_length = ret->vbuffer.length;
+ data = (guint8 *) v4l2_mmap (0, ret->vbuffer.length,
+diff --git a/sys/v4l2/v4l2_calls.c b/sys/v4l2/v4l2_calls.c
+index 309bfb6..ee3ff9f 100644
+--- a/sys/v4l2/v4l2_calls.c
++++ b/sys/v4l2/v4l2_calls.c
+@@ -53,14 +53,6 @@
+
+ #include "gst/gst-i18n-plugin.h"
+
+-/* Those are ioctl calls */
+-#ifndef V4L2_CID_HCENTER
+-#define V4L2_CID_HCENTER V4L2_CID_HCENTER_DEPRECATED
+-#endif
+-#ifndef V4L2_CID_VCENTER
+-#define V4L2_CID_VCENTER V4L2_CID_VCENTER_DEPRECATED
+-#endif
+-
+ GST_DEBUG_CATEGORY_EXTERN (v4l2_debug);
+ #define GST_CAT_DEFAULT v4l2_debug
+
+@@ -294,8 +286,12 @@ gst_v4l2_fill_lists (GstV4l2Object * v4l2object)
+ break;
+ case V4L2_CID_HFLIP:
+ case V4L2_CID_VFLIP:
++#ifdef V4L2_CID_HCENTER
+ case V4L2_CID_HCENTER:
++#endif
++#ifdef V4L2_CID_VCENTER
+ case V4L2_CID_VCENTER:
++#endif
+ #ifdef V4L2_CID_PAN_RESET
+ case V4L2_CID_PAN_RESET:
+ #endif
+--
+1.7.1
+
diff --git a/main/gst-plugins-good/APKBUILD b/main/gst-plugins-good/APKBUILD
index 3e1b977663..02369bf308 100644
--- a/main/gst-plugins-good/APKBUILD
+++ b/main/gst-plugins-good/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gst-plugins-good
pkgver=0.10.31
-pkgrel=4
+pkgrel=5
pkgdesc="GStreamer Multimedia Framework Good Plugins"
url="http://gstreamer.freedesktop.org/"
arch="all"
@@ -15,7 +15,8 @@ makedepends="gstreamer-dev glib-dev liboil-dev gst-plugins-base-dev
replaces="gst-plugins-bad"
source="http://gstreamer.freedesktop.org/src/gst-plugins-good/gst-plugins-good-$pkgver.tar.bz2
- drop-v4l2_buffer-input.patch"
+ 0001-sys-v4l2-Some-blind-compilation-fixes.patch
+ "
depends_dev="gstreamer-dev gst-plugins-base-dev"
@@ -65,4 +66,8 @@ gnome() {
}
md5sums="24f98a294a2b521e1b29412bdadae2e6 gst-plugins-good-0.10.31.tar.bz2
-2a41119f95d623ae7fc960ae12b951de drop-v4l2_buffer-input.patch"
+50a54d7ad0ce0903e25d7059ccd157e4 0001-sys-v4l2-Some-blind-compilation-fixes.patch"
+sha256sums="7e27840e40a7932ef2dc032d7201f9f41afcaf0b437daf5d1d44dc96d9e35ac6 gst-plugins-good-0.10.31.tar.bz2
+24f615180a99c2034d81d783c3f8ac5493205966e272daaff5cb1d06e08e0a2f 0001-sys-v4l2-Some-blind-compilation-fixes.patch"
+sha512sums="dc81eb37cdd9f656419d967347a9b85ce51ae5733680317ac2c84d82816b6dbd1117ae3ef1a5c7d01e90cdc791d3d27ee9e8355a2793ea381a873809c9566bbe gst-plugins-good-0.10.31.tar.bz2
+de2f1257f2341b01cdf2832a40ed6979c04b86ee89a70f9649ff46bf4255cae5f969a4f8f864d39fed7352edb0184c6b5954ac0f27a20cefce61dde25ad36190 0001-sys-v4l2-Some-blind-compilation-fixes.patch"
diff --git a/main/gst-plugins-good/drop-v4l2_buffer-input.patch b/main/gst-plugins-good/drop-v4l2_buffer-input.patch
deleted file mode 100644
index 5db1da7b1a..0000000000
--- a/main/gst-plugins-good/drop-v4l2_buffer-input.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-Fixes build on newer linux kernel headers
-
-Based on:
-http://cgit.freedesktop.org/gstreamer/gst-plugins-good/commit/?id=9f2aa8d47f835ea155aaf635f618c0fc1ca87012
-
---- ./sys/v4l2/gstv4l2bufferpool.c.orig
-+++ ./sys/v4l2/gstv4l2bufferpool.c
-@@ -181,7 +181,6 @@
- GST_LOG_OBJECT (pool->v4l2elem, " MMAP offset: %u",
- ret->vbuffer.m.offset);
- GST_LOG_OBJECT (pool->v4l2elem, " length: %u", ret->vbuffer.length);
-- GST_LOG_OBJECT (pool->v4l2elem, " input: %u", ret->vbuffer.input);
-
- data = (guint8 *) v4l2_mmap (0, ret->vbuffer.length,
- PROT_READ | PROT_WRITE, MAP_SHARED, pool->video_fd,