aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-01-12 11:00:41 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-01-12 11:01:18 +0000
commitd59723f5a7be7b47e478770775014a5e04bb3a61 (patch)
treea0ad2e863e5b44acb94013251c38c41bf71b8e4f
parenta7a6a94120b4415aa814ac223b63b5723e1666ab (diff)
downloadaports-d59723f5a7be7b47e478770775014a5e04bb3a61.tar.bz2
aports-d59723f5a7be7b47e478770775014a5e04bb3a61.tar.xz
testing/libraw: new aport
Library for reading RAW files obtained from digital photo cameras http://www.libraw.org/
-rw-r--r--testing/libraw/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/testing/libraw/APKBUILD b/testing/libraw/APKBUILD
new file mode 100644
index 0000000000..1d4d3ffb7c
--- /dev/null
+++ b/testing/libraw/APKBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libraw
+pkgver=0.12.3
+pkgrel=0
+pkgdesc="Library for reading RAW files obtained from digital photo cameras"
+url="http://www.libraw.org/"
+arch="all"
+license="CDDL LGPL custom"
+depends=""
+makedepends=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://www.libraw.org/data/LibRaw-$pkgver.tar.gz"
+
+_builddir="$srcdir"/LibRaw-$pkgver
+prepare() {
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) patch -p1 -i "$srcdir"/$i || return 1
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr
+ make lib/libraw.a lib/libraw_r.a
+ make
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="b6bd7e6cfed56628068708f61057f691 LibRaw-0.12.3.tar.gz"