aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-27 01:15:10 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-27 01:15:32 -0300
commitd9d11d2f00204f5f0152b7605035160f841e6aef (patch)
treede3224439e22b4e0dbff5c8b580f38884591688e
parent3792875e4e2fcac7bbe8d46f8eaa111ca1455dd9 (diff)
downloadaports-d9d11d2f00204f5f0152b7605035160f841e6aef.tar.bz2
aports-d9d11d2f00204f5f0152b7605035160f841e6aef.tar.xz
community/py-futures: upgrade to 3.3.0
-rw-r--r--community/py-futures/APKBUILD16
1 files changed, 7 insertions, 9 deletions
diff --git a/community/py-futures/APKBUILD b/community/py-futures/APKBUILD
index 9619a36636..a80b189de9 100644
--- a/community/py-futures/APKBUILD
+++ b/community/py-futures/APKBUILD
@@ -2,24 +2,22 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py-futures
_pkgname=futures
-pkgver=3.2.0
+pkgver=3.3.0
pkgrel=0
pkgdesc="Backport of the concurrent.futures package from Python 3.2"
-url="http://code.google.com/p/pythonfutures/"
+url="https://github.com/agronholm/pythonfutures"
arch="noarch"
-license="BSD"
-makedepends="python2-dev"
+license="Python-2.0"
+makedepends="py-setuptools"
subpackages="py2-${pkgname/py-/}:_py2"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-builddir="$srcdir"/$_pkgname-$pkgver
+source="$pkgname-$pkgver.tar.gz::https://github.com/agronholm/pythonfutures/archive/$pkgver.tar.gz"
+builddir="$srcdir"/python$_pkgname-$pkgver
check() {
- cd "$builddir"
python2 setup.py check
}
build() {
- cd "$builddir"
python2 setup.py build
}
@@ -40,4 +38,4 @@ _py2() {
replaces="$pkgname"
}
-sha512sums="e8c08ebc38d7397b5c2a5dc8c22567af1a1b6d5ce6fb8c189f663fb25b96f1ebcbade1ec0a95e9970dfac73606ecd5d7c6f79cc010fd62930a5b005d9babdde0 futures-3.2.0.tar.gz"
+sha512sums="9743291af6632192d21590f93baef7813de524c4c7a33c2da94977e58125d9c21289130bb13494fba964955a6dabdcbf5ab2721c6a0bceab70148762f533abe1 py-futures-3.3.0.tar.gz"