aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-01-29 11:00:08 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-01-29 11:00:08 +0100
commitdae6d52bd4a0588c20bef84aa2d2801b6f4c3541 (patch)
tree43fdf8583e1912b310c8940fcb8f066acc667486
parent514b33979e995913fa91954af293519cedb03c34 (diff)
downloadaports-dae6d52bd4a0588c20bef84aa2d2801b6f4c3541.tar.bz2
aports-dae6d52bd4a0588c20bef84aa2d2801b6f4c3541.tar.xz
Remove the last stale files
-rw-r--r--community/openjdk7/icedtea-jdk-fix-freetype-detection.patch20
-rw-r--r--community/openjdk7/icedtea-jdk-no-lib-nsl-uclibc.patch84
-rw-r--r--main/mariadb/fix-plugin-dir.patch11
-rw-r--r--main/xen/xend.confd3
-rw-r--r--main/xen/xend.initd52
5 files changed, 0 insertions, 170 deletions
diff --git a/community/openjdk7/icedtea-jdk-fix-freetype-detection.patch b/community/openjdk7/icedtea-jdk-fix-freetype-detection.patch
deleted file mode 100644
index 2870b28db0..0000000000
--- a/community/openjdk7/icedtea-jdk-fix-freetype-detection.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- openjdk/jdk/make/tools/freetypecheck/freetypecheck.c.orig
-+++ openjdk/jdk/make/tools/freetypecheck/freetypecheck.c
-@@ -84,7 +84,7 @@
- QUOTEMACRO(REQUIRED_FREETYPE_VERSION));
-
- printf("Detected freetype headers: %s\n", v);
-- if (strcmp(v, QUOTEMACRO(REQUIRED_FREETYPE_VERSION)) < 0) {
-+ if (strverscmp(v, QUOTEMACRO(REQUIRED_FREETYPE_VERSION)) < 0) {
- printf("Failed: headers are too old.\n");
- }
-
-@@ -93,7 +93,7 @@
- sprintf(v, "%d.%d.%d", major, minor, patch);
-
- printf("Detected freetype library: %s\n", v);
-- if (strcmp(v, QUOTEMACRO(REQUIRED_FREETYPE_VERSION)) < 0) {
-+ if (strverscmp(v, QUOTEMACRO(REQUIRED_FREETYPE_VERSION)) < 0) {
- printf("Failed: too old library.\n");
- }
-
diff --git a/community/openjdk7/icedtea-jdk-no-lib-nsl-uclibc.patch b/community/openjdk7/icedtea-jdk-no-lib-nsl-uclibc.patch
deleted file mode 100644
index 26f89bb546..0000000000
--- a/community/openjdk7/icedtea-jdk-no-lib-nsl-uclibc.patch
+++ /dev/null
@@ -1,84 +0,0 @@
---- openjdk.orig/hotspot/agent/src/os/solaris/dbx/Makefile
-+++ openjdk/hotspot/agent/src/os/solaris/dbx/Makefile
-@@ -50,7 +50,7 @@
- CFLAGS_32bit := -xarch=v8
- CFLAGS_64bit := -xarch=v9
- CFLAGS := -PIC -xO3 $(INCLUDES)
--LIBS := -lsocket -lnsl -lrtld_db
-+LIBS := -lsocket -lrtld_db
- LDFLAGS := -G
-
- ifneq "$(ARCH)" "i486"
---- openjdk.orig/jdk/make/java/hpi/hpi_common.gmk
-+++ openjdk/jdk/make/java/hpi/hpi_common.gmk
-@@ -86,5 +86,5 @@
- # Things that must be linked in.
- #
- ifneq ($(PLATFORM), windows)
--OTHER_LDLIBS += $(LIBSOCKET) -lnsl $(LIBM) -ldl
-+OTHER_LDLIBS += $(LIBSOCKET) $(LIBM) -ldl
- endif
---- openjdk.orig/jdk/make/java/java/Makefile
-+++ openjdk/jdk/make/java/java/Makefile
-@@ -205,7 +205,7 @@
- OTHER_LDLIBS += $(JVMLIB) -libpath:$(OBJDIR)/../../../fdlibm/$(OBJDIRNAME) fdlibm.lib \
- -libpath:$(OBJDIR)/../../../verify/$(OBJDIRNAME) verify.lib
- else
--OTHER_LDLIBS += $(JVMLIB) -lverify $(LIBSOCKET) -lnsl -ldl \
-+OTHER_LDLIBS += $(JVMLIB) -lverify $(LIBSOCKET) -ldl \
- -L$(OBJDIR)/../../../fdlibm/$(OBJDIRNAME) -lfdlibm.$(ARCH)
- endif
-
---- openjdk.orig/jdk/make/java/java_hprof_demo/Makefile
-+++ openjdk/jdk/make/java/java_hprof_demo/Makefile
-@@ -83,7 +83,7 @@
- ifeq ($(PLATFORM), windows)
- OTHER_LDLIBS += wsock32.lib winmm.lib
- else
-- OTHER_LDLIBS += $(LIBSOCKET) -lnsl -ldl
-+ OTHER_LDLIBS += $(LIBSOCKET) -ldl
- endif
-
- #
---- openjdk.orig/jdk/make/java/net/Makefile
-+++ openjdk/jdk/make/java/net/Makefile
-@@ -97,7 +97,7 @@
- # Will not compile at warning level 3 if warnings are fatal
- COMPILER_WARNINGS_FATAL=false
- else
-- OTHER_LDLIBS = $(LIBSOCKET) -lnsl -ldl $(JVMLIB)
-+ OTHER_LDLIBS = $(LIBSOCKET) -ldl $(JVMLIB)
- endif
- ifeq ($(PLATFORM), linux)
- OTHER_LDLIBS += -lpthread
---- openjdk.orig/jdk/make/jpda/transport/socket/Makefile
-+++ openjdk/jdk/make/jpda/transport/socket/Makefile
-@@ -42,11 +42,11 @@
- endif
-
- ifeq ($(PLATFORM), linux)
-- OTHER_LDLIBS += -lnsl $(LIBSOCKET) -lpthread
-+ OTHER_LDLIBS += $(LIBSOCKET) -lpthread
- endif
-
- ifeq ($(PLATFORM), solaris)
-- OTHER_LDLIBS += -lnsl $(LIBSOCKET)
-+ OTHER_LDLIBS += $(LIBSOCKET)
- endif
-
- ifeq ($(PLATFORM), windows)
---- openjdk.orig/jdk/make/mkdemo/jvmti/hprof/Makefile
-+++ openjdk/jdk/make/mkdemo/jvmti/hprof/Makefile
-@@ -39,10 +39,10 @@
- EXTRA_LIBS += wsock32.lib winmm.lib
- endif
- ifeq ($(PLATFORM), solaris)
-- OTHER_LDLIBS += $(LIBSOCKET) -lnsl -ldl
-+ OTHER_LDLIBS += $(LIBSOCKET) -ldl
- endif
- ifeq ($(PLATFORM), linux)
-- OTHER_LDLIBS += $(LIBSOCKET) -lnsl -ldl -lpthread
-+ OTHER_LDLIBS += $(LIBSOCKET) -ldl -lpthread
- endif
-
- #
diff --git a/main/mariadb/fix-plugin-dir.patch b/main/mariadb/fix-plugin-dir.patch
deleted file mode 100644
index 1a990cf0eb..0000000000
--- a/main/mariadb/fix-plugin-dir.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/scripts/mysql_install_db.sh
-+++ b/scripts/mysql_install_db.sh
-@@ -358,7 +358,7 @@
- cannot_find_file fill_help_tables.sql @pkgdata_locations@
- exit 1
- fi
-- plugindir=`find_in_dirs --dir auth_pam.so $basedir/lib*/plugin $basedir/lib*/mysql/plugin`
-+ plugindir=`find_in_dirs --dir auth_pam.so $basedir/lib*/plugin $basedir/lib*/mysql/plugin $basedir/lib*/mariadb/plugin`
- pamtooldir=$plugindir
- # relative from where the script was run for a relocatable install
- elif test -n "$dirname0" -a -x "$rel_mysqld" -a ! "$rel_mysqld" -ef "@sbindir@/mysqld"
diff --git a/main/xen/xend.confd b/main/xen/xend.confd
deleted file mode 100644
index 65deada105..0000000000
--- a/main/xen/xend.confd
+++ /dev/null
@@ -1,3 +0,0 @@
-# xend.conf
-
-# XEND_START_TIMEOUT=5
diff --git a/main/xen/xend.initd b/main/xen/xend.initd
deleted file mode 100644
index 0c5164bb17..0000000000
--- a/main/xen/xend.initd
+++ /dev/null
@@ -1,52 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/files/xend.initd-r2,v 1.2 2011/09/10 17:22:46 alexxy Exp $
-
-depend() {
- need xenconsoled xenstored
- after firewall
- before xendomains sshd
-}
-
-await_daemons_up() {
- local i=1 rets=10
- while [ $i -lt $rets ]; do
- /usr/sbin/xend status && return 0
- sleep 1
- done
- return 1
-}
-
-is_privileged_domain() {
- grep -qsE '^control_d$' /proc/xen/capabilities
- return $?
-}
-
-start() {
- if ! is_privileged_domain ; then
- eerror "Can't start xend - this is not a privileged domain."
- return 1
- fi
-
- ebegin "Starting Xen control daemon"
- /usr/sbin/xend start
- /usr/sbin/xend status || await_daemons_up
- eend $?
-}
-
-stop() {
- if [ "$(xm list | wc -l)" -gt 2 ]; then
- ebegin " Stopping all domains"
- /usr/sbin/xl shutdown -a -w >/dev/null
- eend $?
- fi
-
- ebegin "Stopping Xen control daemon"
- /usr/sbin/xend stop
- eend $?
-}
-
-status() {
- is_privileged_domain && /usr/sbin/xend status
-}