aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2017-09-19 21:49:08 -0500
committerNatanael Copa <ncopa@alpinelinux.org>2017-09-20 08:02:56 +0000
commitdae7b88f3d7146746e378de46a1b4baf6f897105 (patch)
tree2c42df8ec291fe7ca459bfbdf656210511b0e030
parent05f68d6852d47a4bd2d566a16f618bc22e7b4781 (diff)
downloadaports-dae7b88f3d7146746e378de46a1b4baf6f897105.tar.bz2
aports-dae7b88f3d7146746e378de46a1b4baf6f897105.tar.xz
main/ed: add test suite
-rw-r--r--main/ed/APKBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/main/ed/APKBUILD b/main/ed/APKBUILD
index c681a6820f..c8da626296 100644
--- a/main/ed/APKBUILD
+++ b/main/ed/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Breno Leitao <breno.leitao@gmail.com>
pkgname=ed
pkgver=1.14.2
-pkgrel=1
+pkgrel=2
pkgdesc="GNU ed is a line-oriented text editor. It is used to create, display, modify and otherwise manipulate text files"
url="https://www.gnu.org/software/ed/"
arch="all"
@@ -25,6 +25,11 @@ build() {
make all
}
+check() {
+ cd "$builddir"
+ make check
+}
+
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install