aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-12-04 10:47:07 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-12-04 10:49:21 +0000
commitdde225b4e88039a27e1ee33216a79c56775c446b (patch)
tree32e79bce18403f544ec7d302bf11a868d0202088
parentbb7703ed87183628e75cfa1f8f7e6da2c44c2f41 (diff)
downloadaports-dde225b4e88039a27e1ee33216a79c56775c446b.tar.bz2
aports-dde225b4e88039a27e1ee33216a79c56775c446b.tar.xz
main/doas: misc improvements in default config
move it to a heredoc in APKBUILD. fewer files in the aports tree. use wheel group in the commented config. This is closer to what we do with sudo.
-rw-r--r--main/doas/APKBUILD19
1 files changed, 11 insertions, 8 deletions
diff --git a/main/doas/APKBUILD b/main/doas/APKBUILD
index 90f2b5fe0d..e55a788bf3 100644
--- a/main/doas/APKBUILD
+++ b/main/doas/APKBUILD
@@ -1,17 +1,14 @@
# Maintainer: Drew DeVault <sir@cmpwn.com>
pkgname=doas
pkgver=6.6
-pkgrel=1
+pkgrel=2
pkgdesc="OpenBSD's temporary privledge escalation tool"
url="https://github.com/Duncaen/OpenDoas"
arch="all"
license="BSD"
makedepends="bison"
subpackages="$pkgname-doc"
-source="
- $pkgname-$pkgver.tar.gz::https://github.com/Duncaen/OpenDoas/archive/v$pkgver.tar.gz
- doas.conf
-"
+source="$pkgname-$pkgver.tar.gz::https://github.com/Duncaen/OpenDoas/archive/v$pkgver.tar.gz"
builddir="$srcdir/OpenDoas-$pkgver"
options="$options suid"
@@ -33,8 +30,14 @@ check() {
package() {
cd "$builddir"
make install DESTDIR="$pkgdir"
- install -Dm440 "$srcdir"/doas.conf "$pkgdir"/etc/doas.conf
+ install -d "$pkgdir"/etc
+ cat > "$pkgdir"/etc/doas.conf <<-EOF
+ # see doas.conf(5) for configuration details
+
+ # Uncomment to allow group "wheel" to become root
+ # permit persist :wheel
+ EOF
+ chmod 440 "$pkgdir"/etc/doas.conf
}
-sha512sums="0ccd84eda9ec109926bfc58997ef7b0ab47ac75208b7e2f98477ec9f0211dd468d826bfc2758340188c934e6198b98eff0662b684166575f12742c7c1ab05e89 doas-6.6.tar.gz
-5035ae91293953b292c430334e949e11e5b482c5c91c7f018ac8286a791568a3006499649f487547a262291c0968618522fbc14acb5e2faa2af52accf15bbc49 doas.conf"
+sha512sums="0ccd84eda9ec109926bfc58997ef7b0ab47ac75208b7e2f98477ec9f0211dd468d826bfc2758340188c934e6198b98eff0662b684166575f12742c7c1ab05e89 doas-6.6.tar.gz"