aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-08 12:46:58 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-08 13:12:05 -0300
commitde4c2a62d6314351f832d4b182ee4dd0269c530c (patch)
tree1173694492d14fbadd2befc54e5c9701941ec5cf
parentcf2770492e7af931e3dd1f2d3d836abf1d09a46e (diff)
downloadaports-de4c2a62d6314351f832d4b182ee4dd0269c530c.tar.bz2
aports-de4c2a62d6314351f832d4b182ee4dd0269c530c.tar.xz
testing/py3-sphinx-theme-epfl: drop py2
-rw-r--r--testing/py3-sphinx-theme-epfl/APKBUILD34
1 files changed, 10 insertions, 24 deletions
diff --git a/testing/py3-sphinx-theme-epfl/APKBUILD b/testing/py3-sphinx-theme-epfl/APKBUILD
index 1de3ac716b..0a34574170 100644
--- a/testing/py3-sphinx-theme-epfl/APKBUILD
+++ b/testing/py3-sphinx-theme-epfl/APKBUILD
@@ -1,41 +1,27 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-sphinx-theme-epfl
+pkgname=py3-sphinx-theme-epfl
_pkgname=epfl-sphinx-theme
pkgver=1.1.1
-pkgrel=0
+pkgrel=1
pkgdesc="The EPFL Sphinx theme"
url="http://kis-doc.epfl.ch/sphinx/"
arch="noarch"
-license="GPL-3.0"
-depends="python2 py-sphinx"
-depends_dev=""
-makedepends="python2-dev py-setuptools"
-install=""
-subpackages=""
+license="GPL-3.0-only"
+depends="python3 py3-sphinx"
+makedepends="py3-setuptools"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
-_builddir="$srcdir"/$_pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+replaces="py-sphinx-theme-epfl" # Backwards compatibility
+provides="py-sphinx-theme-epfl=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- cd "$_builddir"
- python2 setup.py build || return 1
+ python3 setup.py build
}
package() {
- cd "$_builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-md5sums="5d6d32f2757695b7671f71c6ca58cccd epfl-sphinx-theme-1.1.1.tar.gz"
-sha256sums="fa734959c14dd406f6a79ccfe85edb3f8bf203713d761e911bd00c2c46e11fcf epfl-sphinx-theme-1.1.1.tar.gz"
sha512sums="af36469cbd33c5f8d1a4ebef201838a26dc52c04b1432b6cc49b46bfb74c585aad83da11cc9ebb675ad166573af41b00bed3e4ec770dcd60330599a732196ea0 epfl-sphinx-theme-1.1.1.tar.gz"