aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-28 23:47:17 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-29 01:10:04 -0300
commitdee49ccc79241e4989ae7fc2bf83db3a628dc904 (patch)
treecff22d4239889ee2c3ad57a0233253a93925938f
parent62f4e35c24f6f99c5d618c48011cbdee2601f34f (diff)
downloadaports-dee49ccc79241e4989ae7fc2bf83db3a628dc904.tar.bz2
aports-dee49ccc79241e4989ae7fc2bf83db3a628dc904.tar.xz
testing/py3-flake8-quotes: upgrade to 2.1.0
-rw-r--r--testing/py3-flake8-quotes/APKBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/testing/py3-flake8-quotes/APKBUILD b/testing/py3-flake8-quotes/APKBUILD
index 8e9bf30010..cbcb17cfcb 100644
--- a/testing/py3-flake8-quotes/APKBUILD
+++ b/testing/py3-flake8-quotes/APKBUILD
@@ -2,10 +2,9 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-flake8-quotes
_pkgname=flake8-quotes
-pkgver=2.0.1
+pkgver=2.1.0
pkgrel=0
pkgdesc="Extension for flake8 which lint for double quotes"
-options="!check" # Tries to use flake8 from PyPi not system
url="http://github.com/zheller/flake8-quotes/"
arch="noarch"
license="MIT"
@@ -21,8 +20,12 @@ build() {
python3 setup.py build
}
+check() {
+ python3 setup.py test
+}
+
package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="e86b2915463a25ac5b8ce4dbbae4a8dcef597891ba1439943dd224ab91583927f2a79b15ef303bb774c8f7a12c1d348fda9379e2b782ce9ee49ab16efe0b2f20 flake8-quotes-2.0.1.tar.gz"
+sha512sums="94ccacac3a1ff8b5c8e6ade7568a3784ebcdb7e81d998adeb3f5240eac5c454486578d7a996e96a01ca34e8f510b96ad0cc8872fdc321f9aa8616330e85b0c22 flake8-quotes-2.1.0.tar.gz"