aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKeith Maxwell <keith.maxwell@gmail.com>2020-02-05 11:47:36 +0000
committerLeo <thinkabit.ukim@gmail.com>2020-02-13 09:29:09 -0300
commitdf6aaecc1f4d1b8c7738765effaff2b539874ec0 (patch)
tree359e3b206e4affe2c74ca71a33f253d46056defb
parent6b8af9784ef78bd59bb8bdec40d2231ee0439815 (diff)
downloadaports-df6aaecc1f4d1b8c7738765effaff2b539874ec0.tar.bz2
aports-df6aaecc1f4d1b8c7738765effaff2b539874ec0.tar.xz
testing/beancount: move py3-pytest to depends
The bean-file command which is a part of this package uses pytest at run time. It is used indirectly through <https://bitbucket.org/blais/beancount/src/default/beancount/ingest/__init__.py> which is installed to `usr/lib/python3.8/site-packages/beancount/ingest/__init__.py` and uses pytest at line 13. Before this change: 1. Install beancount: `sudo apk add beancount` 2. Check that `py3-pytest` is not installed: `apk list --installed '*pytest*'` 3. Running `/usr/bin/bean-file` gives the output below: ``` Traceback (most recent call last): File "/usr/bin/bean-file", line 4, in <module> from beancount.ingest.file import main; main() File "/usr/lib/python3.8/site-packages/beancount/ingest/__init__.py", line 13, in <module> import pytest ModuleNotFoundError: No module named 'pytest' ``` After this change `/usr/bin/bean-file` behaves as expected.
-rw-r--r--testing/beancount/APKBUILD5
1 files changed, 2 insertions, 3 deletions
diff --git a/testing/beancount/APKBUILD b/testing/beancount/APKBUILD
index 10265fddaf..3e68ecf8c5 100644
--- a/testing/beancount/APKBUILD
+++ b/testing/beancount/APKBUILD
@@ -2,16 +2,15 @@
# Maintainer: Keith Maxwell <keith.maxwell@gmail.com>
pkgname=beancount
pkgver=2.2.3
-pkgrel=1
+pkgrel=2
pkgdesc="Double-Entry Accounting from Text Files"
url="http://furius.ca/beancount/"
arch="all"
license="GPL-2.0-only"
depends="python3 py3-dateutil py3-ply py3-bottle py3-lxml py3-magic
- py3-beautifulsoup4 py3-requests py3-chardet
+ py3-beautifulsoup4 py3-requests py3-chardet py3-pytest
py3-google-api-python-client"
makedepends="python3-dev py3-setuptools"
-checkdepends="py3-pytest"
source="$pkgname-$pkgver.tar.gz::https://bitbucket.org/blais/beancount/get/$pkgver.tar.gz"
# 0cd71fede0f3347a14ac2b7ed240b74d56a38887 2.2.1
builddir="$srcdir"/blais-$pkgname-ff1e2616b26a