aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2020-02-15 21:53:44 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2020-04-14 17:10:41 +0200
commite199275be33d1c6b83f6009c8e0aa492331237ff (patch)
treed6f31841e4aa6ea93b0de870357677c78ac3b9a0
parente4dd5af8db40c72955e47aa6a03fe3ae08d3126b (diff)
downloadaports-e199275be33d1c6b83f6009c8e0aa492331237ff.tar.bz2
aports-e199275be33d1c6b83f6009c8e0aa492331237ff.tar.xz
community/go: remove default-buildmode-pie.patch
Instead set -buildmode=pie using the GOFLAGS environment variable on the builders (see last commit). Users either have to pass -buildmode=pie explicitly or configure their shell environment accordingly. This fixes the `cannot find runtime/cgo`-warning and will allow running more test cases of the go compiler test suite in the future.
-rw-r--r--community/go/APKBUILD4
-rw-r--r--community/go/default-buildmode-pie.patch27
2 files changed, 1 insertions, 30 deletions
diff --git a/community/go/APKBUILD b/community/go/APKBUILD
index 0b21b8c18e..10c0d1cb49 100644
--- a/community/go/APKBUILD
+++ b/community/go/APKBUILD
@@ -4,7 +4,7 @@
pkgname=go
# go binaries are statically linked, security updates require rebuilds
pkgver=1.13.8
-pkgrel=0
+pkgrel=1
pkgdesc="Go programming language compiler"
url="https://golang.org/"
arch="all"
@@ -14,7 +14,6 @@ makedepends="bash"
checkdepends="binutils-gold"
subpackages="$pkgname-doc"
source="https://golang.org/dl/go${pkgver/_/}.src.tar.gz
- default-buildmode-pie.patch
disable-flaky-sync-test.patch
"
@@ -144,5 +143,4 @@ package() {
}
sha512sums="5df45c4701631e7a70f4f25b07ed00dc9a56bdebeb5ead2d04e0e6b000e8a9f00d193247e626ef5b1e6b7fc54bf27fbc5e8fb21b23ab52ec397f2238c5dfa000 go1.13.8.src.tar.gz
-f0c07d9979fc3165fc78158406de8440624b3f2c6f6542c9889c71efbf3d2f02a7ffee27ccba8c2630489895d331b7b9d3a606162134dcb3e8e0b9fc06b529dc default-buildmode-pie.patch
6ce14ca43fd35520e667530af91cfcad8902d635e6dd8c04d19428299b9e29ba049120f5eebbb00717a895f052d1cc40d3f522c090786625cce726715a8218ec disable-flaky-sync-test.patch"
diff --git a/community/go/default-buildmode-pie.patch b/community/go/default-buildmode-pie.patch
deleted file mode 100644
index 96adcee50c..0000000000
--- a/community/go/default-buildmode-pie.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-diff --git a/src/cmd/go/internal/work/init.go b/src/cmd/go/internal/work/init.go
-index 7f894f5..a37cbf3 100644
---- a/src/cmd/go/internal/work/init.go
-+++ b/src/cmd/go/internal/work/init.go
-@@ -111,7 +111,8 @@ func buildModeInit() {
- ldBuildmode = "c-shared"
- case "default":
- switch platform {
-- case "android/arm", "android/arm64", "android/amd64", "android/386":
-+ case "linux/amd64", "linux/arm", "linux/arm64", "linux/386", "linux/ppc64le", "linux/s390x",
-+ "android/amd64", "android/arm", "android/arm64", "android/386":
- codegenArg = "-shared"
- ldBuildmode = "pie"
- case "darwin/arm", "darwin/arm64":
-diff --git a/src/cmd/dist/test.go b/src/cmd/dist/test.go
-index f63c946..80ad134 100644
---- a/src/cmd/dist/test.go
-+++ b/src/cmd/dist/test.go
-@@ -553,7 +553,7 @@ func (t *tester) registerTests() {
- }
-
- // ARM libgcc may be Thumb, which internal linking does not support.
-- if goarch == "arm" {
-+ if goarch == "arm" || goarch == "s390x" {
- break
- }
-