aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-01 12:12:29 -0300
committerKevin Daudt <kdaudt@alpinelinux.org>2019-06-01 21:13:08 +0000
commite35e1f3775243c6f7f9b16142b976fa1b3cc5e52 (patch)
tree201237864272982318fc21069819c872dbf8eb68
parent3a71970244f7cbe3ab8df3287738781a24cfc25e (diff)
downloadaports-e35e1f3775243c6f7f9b16142b976fa1b3cc5e52.tar.bz2
aports-e35e1f3775243c6f7f9b16142b976fa1b3cc5e52.tar.xz
testing/py-application: modernize
Closes GH-8361
-rw-r--r--testing/py-application/APKBUILD6
1 files changed, 2 insertions, 4 deletions
diff --git a/testing/py-application/APKBUILD b/testing/py-application/APKBUILD
index 039b18f013..6b6c562e5a 100644
--- a/testing/py-application/APKBUILD
+++ b/testing/py-application/APKBUILD
@@ -9,21 +9,19 @@ url="http://pypi.python.org/pypi/python-application"
arch="noarch"
license="LGPL-2.0-or-later"
depends="python2"
-makedepends="python2-dev py-setuptools"
+makedepends="py-setuptools"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
+
build() {
- cd "$builddir"
python2 setup.py build
}
check() {
- cd "$builddir"
python2 setup.py check
}
package() {
- cd "$builddir"
python2 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="8c1c5eb052b4b0b88d94f06a2c7e7d6535c5e7ed08055c90ecc327b2c55b621943ba1be82b898b3e43308cc8556d109bbb3848ea326be972b87543e302db6731 python-application-2.6.0.tar.gz"