aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-10-15 12:43:40 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-10-15 15:04:59 -0300
commite625d5538eb0fd9bd1029083b1d3e36af501dcd0 (patch)
tree2ca694db811f8de6dc795b79915a04effbdfaaf6
parentefaa69489b5eb0a1778a9ee8f03080fd24c8b240 (diff)
downloadaports-e625d5538eb0fd9bd1029083b1d3e36af501dcd0.tar.bz2
aports-e625d5538eb0fd9bd1029083b1d3e36af501dcd0.tar.xz
testing/i3status: rebuild with GLOB_TILDE
-rw-r--r--testing/i3status/APKBUILD9
-rw-r--r--testing/i3status/musl-fix.patch13
2 files changed, 4 insertions, 18 deletions
diff --git a/testing/i3status/APKBUILD b/testing/i3status/APKBUILD
index a83658727a..df310e2a81 100644
--- a/testing/i3status/APKBUILD
+++ b/testing/i3status/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Brian Cole <git@brianecole.com>
pkgname=i3status
pkgver=2.13
-pkgrel=0
+pkgrel=1
pkgdesc="Generates status bar for dzen2, xmobar or similar"
url="https://i3.zekjur.net/i3status"
arch="all"
@@ -10,9 +10,9 @@ license="BSD-3-Clause"
options="!check" # No test suite
makedepends="alsa-lib-dev asciidoc autoconf automake confuse-dev libnl3-dev linux-headers yajl-dev xmlto"
subpackages="$pkgname-doc"
-source="https://i3wm.org/i3status/$pkgname-$pkgver.tar.bz2
- musl-fix.patch
- no-pulseaudio.patch"
+source="https://i3wm.org/i3status/i3status-$pkgver.tar.bz2
+ no-pulseaudio.patch
+ "
build() {
autoreconf -vif
@@ -28,5 +28,4 @@ package() {
}
sha512sums="6dadff19e53499d169ba4f491e1f821014b4f92fc3c93d7947c85cbbbdeaba538d02bd8ab98fe266a8f80756a287fd5803ec77a8cd874d50082b5cad309875c2 i3status-2.13.tar.bz2
-b9d853879885ac04284eb57198251d39bd00b9fae2a0bc8f5b7475a6787699f4f27e40985363efd5a52d4ceee21a4afb58c7b37778e8270b5aade7e0e13e217f musl-fix.patch
759f8e8aba9e5b5b6d390935c440ecfab2a1aaffb92b9cc20aec80e8f0bce2f0b79119991aee349573daf55b421bc1f80a5dc69e554fd16ff7e0ddf69d24c39b no-pulseaudio.patch"
diff --git a/testing/i3status/musl-fix.patch b/testing/i3status/musl-fix.patch
deleted file mode 100644
index a681f940c4..0000000000
--- a/testing/i3status/musl-fix.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- a/include/i3status.h
-+++ b/include/i3status.h
-@@ -29,6 +29,10 @@
- #include <pthread.h>
- #include <stdint.h>
-
-+#ifndef GLOB_TILDE
-+#define GLOB_TILDE 0
-+#endif
-+
- #define BEGINS_WITH(haystack, needle) (strncmp(haystack, needle, strlen(needle)) == 0)
- #define max(a, b) ((a) > (b) ? (a) : (b))
-