aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-07-25 12:18:07 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-07-25 12:24:04 +0000
commite7a2d585a0faeedf75c763676bdd77768cfeb5f8 (patch)
tree09875cf0b5a4981f7470fb04d1fb696f88a601d8
parent831f845023611b28e7fd50e1b5b129f2394b4349 (diff)
downloadaports-e7a2d585a0faeedf75c763676bdd77768cfeb5f8.tar.bz2
aports-e7a2d585a0faeedf75c763676bdd77768cfeb5f8.tar.xz
testing/docker-compose: new aport
Define and run multi-container applications with Docker https://docs.docker.com/compose/
-rw-r--r--testing/docker-compose/APKBUILD51
1 files changed, 51 insertions, 0 deletions
diff --git a/testing/docker-compose/APKBUILD b/testing/docker-compose/APKBUILD
new file mode 100644
index 0000000000..0923c9c613
--- /dev/null
+++ b/testing/docker-compose/APKBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=docker-compose
+pkgver=1.22.0
+pkgrel=0
+pkgdesc="Define and run multi-container applications with Docker"
+url="https://docs.docker.com/compose/"
+arch="all"
+license="apache-2.0"
+depends="python3
+ py3-setuptools
+ docker-py>=3.4.1
+ dockerpy-creds>=0.3.0
+ py3-cached-property>=1.3.0
+ py3-certifi>=2017.4.17
+ py3-chardet>=3.0.4
+ py3-dockerpty>=0.4.1
+ py3-docopt>=0.6.2
+ py3-idna>=2.5
+ py3-ipaddress>=1.0.18
+ py3-jsonschema>=2.6.0
+ py3-pysocks>=1.6.7
+ py3-requests>=2.19.1
+ py3-six>=1.10.0
+ py3-texttable>=0.9.1
+ py3-urllib3>=1.21.1
+ py3-websocket-client>=0.32.0
+ py3-yaml>=3.12
+ "
+checkdepends="py3-pytest py3-nose py3-mock py3-flake8 py3-coverage"
+source="docker-compose-$pkgver.tar.gz::https://github.com/docker/compose/archive/$pkgver.tar.gz"
+builddir="$srcdir/compose-$pkgver"
+options="!check" # many of the tests fail. need more investigation
+
+build() {
+ cd "$builddir"
+ # allow newer version of dependencies
+ sed -e 's/, < [0-9.]\+//' -i setup.py
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python3 setup.py test
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="eccef2165221fcfdac089ffd3bd0795d08d8c6f7158709dbc2fc83a6d6e9466af4b73c0c7d24a751c6b546b4219e10dfc96cd41e13e7ebc676da603c97b7620e docker-compose-1.22.0.tar.gz"