aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2016-01-11 00:41:25 +0100
committerSören Tempel <soeren+git@soeren-tempel.net>2016-01-11 01:05:25 +0100
commite8d22a7d4c0f6efd25d2203d78914bb35a03bad3 (patch)
tree4550f1f511e3dad4910376eab3d08fcacdc483c2
parent087996ce6e46292718da7235a61b6ccd6259436d (diff)
downloadaports-e8d22a7d4c0f6efd25d2203d78914bb35a03bad3.tar.bz2
aports-e8d22a7d4c0f6efd25d2203d78914bb35a03bad3.tar.xz
testing/dvtm: use the default configuration file
-rw-r--r--testing/dvtm/APKBUILD21
-rw-r--r--testing/dvtm/config.h223
2 files changed, 6 insertions, 238 deletions
diff --git a/testing/dvtm/APKBUILD b/testing/dvtm/APKBUILD
index 6cdbefd34e..d48ccfa721 100644
--- a/testing/dvtm/APKBUILD
+++ b/testing/dvtm/APKBUILD
@@ -3,22 +3,16 @@
# Maintainer:
pkgname=dvtm
pkgver=0.14
-pkgrel=0
+pkgrel=1
pkgdesc="Dynamic virtual terminal manager"
arch="all"
url="http://www.brain-dump.org/projects/dvtm/"
license="MIT"
makedepends="ncurses-dev ncurses" # we need ncurses for 'tic'
subpackages="$pkgname-doc"
-source="http://www.brain-dump.org/projects/${pkgname}/${pkgname}-${pkgver}.tar.gz
- config.h"
+source="http://www.brain-dump.org/projects/${pkgname}/${pkgname}-${pkgver}.tar.gz"
_builddir="$srcdir"/$pkgname-$pkgver
-prepare() {
- cd "$_builddir"
- cp "$srcdir"/config.h .
-}
-
build() {
cd "$_builddir"
make || return 1
@@ -26,12 +20,9 @@ build() {
package() {
cd "$_builddir"
- make PREFIX=/usr DESTDIR="${pkgdir}" install || return 1
+ make PREFIX=/usr DESTDIR="$pkgdir" install || return 1
}
-md5sums="44ec5176b1996fdffd97cabe9a35ea0c dvtm-0.14.tar.gz
-6236b8871baef14f55fd75b4aaddc70e config.h"
-sha256sums="8a9bb341f8a4c578b839e22d9a707f053a27ae6df15158e16f4fee787e43747a dvtm-0.14.tar.gz
-81a84c597a811191026b92b73fd44e8410d1759e244e4b259010a78c5e4c0d91 config.h"
-sha512sums="d47f55b4ce47582f665ac5b5d86bb9137722f65b157bdd80aaaf45a2cd8d783a3b0718886c7a7ea1d900762359316c2d76816460dac03484e122d43c64f57dd6 dvtm-0.14.tar.gz
-9bd5a38a95421b80b526209d1ada8805d4a2b510c0e9532917e8a91cbf1e9ae633f5b52c020f091b991dafecf3279fbd1fe49565552e469aeb2ee777ce563e7b config.h"
+md5sums="44ec5176b1996fdffd97cabe9a35ea0c dvtm-0.14.tar.gz"
+sha256sums="8a9bb341f8a4c578b839e22d9a707f053a27ae6df15158e16f4fee787e43747a dvtm-0.14.tar.gz"
+sha512sums="d47f55b4ce47582f665ac5b5d86bb9137722f65b157bdd80aaaf45a2cd8d783a3b0718886c7a7ea1d900762359316c2d76816460dac03484e122d43c64f57dd6 dvtm-0.14.tar.gz"
diff --git a/testing/dvtm/config.h b/testing/dvtm/config.h
deleted file mode 100644
index b0a68d407d..0000000000
--- a/testing/dvtm/config.h
+++ /dev/null
@@ -1,223 +0,0 @@
-/* valid curses attributes are listed below they can be ORed
- *
- * A_NORMAL Normal display (no highlight)
- * A_STANDOUT Best highlighting mode of the terminal.
- * A_UNDERLINE Underlining
- * A_REVERSE Reverse video
- * A_BLINK Blinking
- * A_DIM Half bright
- * A_BOLD Extra bright or bold
- * A_PROTECT Protected mode
- * A_INVIS Invisible or blank mode
- */
-
-enum {
- DEFAULT,
- BLUE,
-};
-
-static Color colors[] = {
- [DEFAULT] = { .fg = -1, .bg = -1, .fg256 = -1, .bg256 = -1, },
- [BLUE] = { .fg = COLOR_BLUE, .bg = -1, .fg256 = 68, .bg256 = -1, },
-};
-
-#define COLOR(c) COLOR_PAIR(colors[c].pair)
-/* curses attributes for the currently focused window */
-#define SELECTED_ATTR (COLOR(BLUE) | A_NORMAL)
-/* curses attributes for normal (not selected) windows */
-#define NORMAL_ATTR (COLOR(DEFAULT) | A_NORMAL)
-/* curses attributes for a window with pending urgent flag */
-#define URGENT_ATTR NORMAL_ATTR
-/* curses attributes for the status bar */
-#define BAR_ATTR (COLOR(BLUE) | A_NORMAL)
-/* status bar (command line option -s) position */
-#define BAR_POS BAR_TOP /* BAR_BOTTOM, BAR_OFF */
-/* whether status bar should be hidden if only one client exists */
-#define BAR_AUTOHIDE true
-/* master width factor [0.1 .. 0.9] */
-#define MFACT 0.5
-/* number of clients in master area */
-#define NMASTER 1
-/* scroll back buffer size in lines */
-#define SCROLL_HISTORY 500
-/* printf format string for the tag in the status bar */
-#define TAG_SYMBOL "[%s]"
-/* curses attributes for the currently selected tags */
-#define TAG_SEL (COLOR(BLUE) | A_BOLD)
-/* curses attributes for not selected tags which contain no windows */
-#define TAG_NORMAL (COLOR(DEFAULT) | A_NORMAL)
-/* curses attributes for not selected tags which contain windows */
-#define TAG_OCCUPIED (COLOR(BLUE) | A_NORMAL)
-/* curses attributes for not selected tags which with urgent windows */
-#define TAG_URGENT (COLOR(BLUE) | A_NORMAL | A_BLINK)
-
-const char tags[][8] = { "1", "2", "3", "4", "5" };
-
-#include "tile.c"
-#include "grid.c"
-#include "bstack.c"
-#include "fullscreen.c"
-
-/* by default the first layout entry is used */
-static Layout layouts[] = {
- { "[]=", tile },
- { "+++", grid },
- { "TTT", bstack },
- { "[ ]", fullscreen },
-};
-
-#define MOD CTRL('g')
-
-/* you can at most specifiy MAX_ARGS (3) number of arguments */
-static KeyBinding bindings[] = {
- { { MOD, 'c', }, { create, { NULL } } },
- { { MOD, 'C', }, { create, { NULL, NULL, "$CWD" } } },
- { { MOD, 'x', }, { killclient, { NULL } } },
- { { MOD, 'j', }, { focusnext, { NULL } } },
- { { MOD, 'J', }, { focusnextnm, { NULL } } },
- { { MOD, 'K', }, { focusprevnm, { NULL } } },
- { { MOD, 'k', }, { focusprev, { NULL } } },
- { { MOD, 'f', }, { setlayout, { "[]=" } } },
- { { MOD, 'g', }, { setlayout, { "+++" } } },
- { { MOD, 'b', }, { setlayout, { "TTT" } } },
- { { MOD, 'm', }, { setlayout, { "[ ]" } } },
- { { MOD, ' ', }, { setlayout, { NULL } } },
- { { MOD, 'i', }, { incnmaster, { "+1" } } },
- { { MOD, 'd', }, { incnmaster, { "-1" } } },
- { { MOD, 'h', }, { setmfact, { "-0.05" } } },
- { { MOD, 'l', }, { setmfact, { "+0.05" } } },
- { { MOD, '.', }, { toggleminimize, { NULL } } },
- { { MOD, 's', }, { togglebar, { NULL } } },
- { { MOD, 'S', }, { togglebarpos, { NULL } } },
- { { MOD, 'M', }, { togglemouse, { NULL } } },
- { { MOD, '\n', }, { zoom , { NULL } } },
- { { MOD, '\r', }, { zoom , { NULL } } },
- { { MOD, '1', }, { focusn, { "1" } } },
- { { MOD, '2', }, { focusn, { "2" } } },
- { { MOD, '3', }, { focusn, { "3" } } },
- { { MOD, '4', }, { focusn, { "4" } } },
- { { MOD, '5', }, { focusn, { "5" } } },
- { { MOD, '6', }, { focusn, { "6" } } },
- { { MOD, '7', }, { focusn, { "7" } } },
- { { MOD, '8', }, { focusn, { "8" } } },
- { { MOD, '9', }, { focusn, { "9" } } },
- { { MOD, '\t', }, { focuslast, { NULL } } },
- { { MOD, 'q', }, { quit, { NULL } } },
- { { MOD, 'a', }, { togglerunall, { NULL } } },
- { { MOD, CTRL('L'), }, { redraw, { NULL } } },
- { { MOD, 'r', }, { redraw, { NULL } } },
- { { MOD, 'e', }, { copymode, { NULL } } },
- { { MOD, '/', }, { copymode, { "/" } } },
- { { MOD, 'p', }, { paste, { NULL } } },
- { { MOD, KEY_PPAGE, }, { scrollback, { "-1" } } },
- { { MOD, KEY_NPAGE, }, { scrollback, { "1" } } },
- { { MOD, '?', }, { create, { "man dvtm", "dvtm help" } } },
- { { MOD, MOD, }, { send, { (const char []){MOD, 0} } } },
- { { KEY_SPREVIOUS, }, { scrollback, { "-1" } } },
- { { KEY_SNEXT, }, { scrollback, { "1" } } },
- { { MOD, '0', }, { view, { NULL } } },
- { { MOD, KEY_F(1), }, { view, { tags[0] } } },
- { { MOD, KEY_F(2), }, { view, { tags[1] } } },
- { { MOD, KEY_F(3), }, { view, { tags[2] } } },
- { { MOD, KEY_F(4), }, { view, { tags[3] } } },
- { { MOD, KEY_F(5), }, { view, { tags[4] } } },
- { { MOD, 'v', '0' }, { view, { NULL } } },
- { { MOD, 'v', '1' }, { view, { tags[0] } } },
- { { MOD, 'v', '2' }, { view, { tags[1] } } },
- { { MOD, 'v', '3' }, { view, { tags[2] } } },
- { { MOD, 'v', '4' }, { view, { tags[3] } } },
- { { MOD, 'v', '5' }, { view, { tags[4] } } },
- { { MOD, 'v', '\t', }, { viewprevtag, { NULL } } },
- { { MOD, 't', '0' }, { tag, { NULL } } },
- { { MOD, 't', '1' }, { tag, { tags[0] } } },
- { { MOD, 't', '2' }, { tag, { tags[1] } } },
- { { MOD, 't', '3' }, { tag, { tags[2] } } },
- { { MOD, 't', '4' }, { tag, { tags[3] } } },
- { { MOD, 't', '5' }, { tag, { tags[4] } } },
- { { MOD, 'V', '1' }, { toggleview, { tags[0] } } },
- { { MOD, 'V', '2' }, { toggleview, { tags[1] } } },
- { { MOD, 'V', '3' }, { toggleview, { tags[2] } } },
- { { MOD, 'V', '4' }, { toggleview, { tags[3] } } },
- { { MOD, 'V', '5' }, { toggleview, { tags[4] } } },
- { { MOD, 'T', '1' }, { toggletag, { tags[0] } } },
- { { MOD, 'T', '2' }, { toggletag, { tags[1] } } },
- { { MOD, 'T', '3' }, { toggletag, { tags[2] } } },
- { { MOD, 'T', '4' }, { toggletag, { tags[3] } } },
- { { MOD, 'T', '5' }, { toggletag, { tags[4] } } },
-};
-
-static const ColorRule colorrules[] = {
- { "", A_NORMAL, &colors[DEFAULT] }, /* default */
-};
-
-/* possible values for the mouse buttons are listed below:
- *
- * BUTTON1_PRESSED mouse button 1 down
- * BUTTON1_RELEASED mouse button 1 up
- * BUTTON1_CLICKED mouse button 1 clicked
- * BUTTON1_DOUBLE_CLICKED mouse button 1 double clicked
- * BUTTON1_TRIPLE_CLICKED mouse button 1 triple clicked
- * BUTTON2_PRESSED mouse button 2 down
- * BUTTON2_RELEASED mouse button 2 up
- * BUTTON2_CLICKED mouse button 2 clicked
- * BUTTON2_DOUBLE_CLICKED mouse button 2 double clicked
- * BUTTON2_TRIPLE_CLICKED mouse button 2 triple clicked
- * BUTTON3_PRESSED mouse button 3 down
- * BUTTON3_RELEASED mouse button 3 up
- * BUTTON3_CLICKED mouse button 3 clicked
- * BUTTON3_DOUBLE_CLICKED mouse button 3 double clicked
- * BUTTON3_TRIPLE_CLICKED mouse button 3 triple clicked
- * BUTTON4_PRESSED mouse button 4 down
- * BUTTON4_RELEASED mouse button 4 up
- * BUTTON4_CLICKED mouse button 4 clicked
- * BUTTON4_DOUBLE_CLICKED mouse button 4 double clicked
- * BUTTON4_TRIPLE_CLICKED mouse button 4 triple clicked
- * BUTTON_SHIFT shift was down during button state change
- * BUTTON_CTRL control was down during button state change
- * BUTTON_ALT alt was down during button state change
- * ALL_MOUSE_EVENTS report all button state changes
- * REPORT_MOUSE_POSITION report mouse movement
- */
-
-#ifdef NCURSES_MOUSE_VERSION
-# define CONFIG_MOUSE /* compile in mouse support if we build against ncurses */
-#endif
-
-#define ENABLE_MOUSE true /* whether to enable mouse events by default */
-
-#ifdef CONFIG_MOUSE
-static Button buttons[] = {
- { BUTTON1_CLICKED, { mouse_focus, { NULL } } },
- { BUTTON1_DOUBLE_CLICKED, { mouse_fullscreen, { "[ ]" } } },
- { BUTTON2_CLICKED, { mouse_zoom, { NULL } } },
- { BUTTON3_CLICKED, { mouse_minimize, { NULL } } },
-};
-#endif /* CONFIG_MOUSE */
-
-static Cmd commands[] = {
- { "create", { create, { NULL } } },
-};
-
-/* gets executed when dvtm is started */
-static Action actions[] = {
- { create, { NULL } },
-};
-
-static char const * const keytable[] = {
- /* add your custom key escape sequences */
-};
-
-/* editor to use for copy mode. If neither of DVTM_EDITOR, EDITOR and PAGER is
- * set the first entry is chosen. Otherwise the array is consulted for supported
- * options. A %d in argv is replaced by the line number at which the file should
- * be opened. If filter is true the editor is expected to work even if stdout is
- * redirected (i.e. not a terminal).
- */
-static Editor editors[] = {
- { .name = "vis", .argv = { "vis", "+%d", "-", NULL }, .filter = true },
- { .name = "sandy", .argv = { "sandy", "-d", "-", NULL }, .filter = true },
- { .name = "dvtm-editor", .argv = { "dvtm-editor", "-", NULL }, .filter = true },
- { .name = "vim", .argv = { "vim", "+%d", "-", NULL }, .filter = false },
- { .name = "less", .argv = { "less", "+%d", NULL }, .filter = false },
- { .name = "more", .argv = { "more", "+%d", NULL }, .filter = false },
-};