aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-05-07 00:22:09 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-05-07 14:32:55 +0200
commiteae3085afd6e414eeb09a21e044107ed33e5d6f6 (patch)
tree813762b39d31d052294488e40f6513d4a0f85acb
parentacc76240a597f0c4890459c3aeccda9a04de1fd7 (diff)
downloadaports-eae3085afd6e414eeb09a21e044107ed33e5d6f6.tar.bz2
aports-eae3085afd6e414eeb09a21e044107ed33e5d6f6.tar.xz
testing/unit: really run tests
-rw-r--r--testing/unit/APKBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/testing/unit/APKBUILD b/testing/unit/APKBUILD
index d38dddb7c1..d299f9ed9e 100644
--- a/testing/unit/APKBUILD
+++ b/testing/unit/APKBUILD
@@ -21,15 +21,22 @@ build() {
--control="unix:/run/control.unit.sock" \
--pid="/run/unit.pid" \
--log="/var/log/unit.log" \
- --modules="/usr/lib/unit/modules"
+ --modules="/usr/lib/unit/modules" \
+ --tests
./configure python \
--config=python3-config
make
+ make tests
}
check() {
cd "$builddir"
- ./test/run.py
+
+ ./build/tests
+
+ # FIXME: Some tests are broken.
+ #make install DESTDIR=".dest"
+ #./test/run.py
}
package() {