aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-30 22:21:44 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-07-01 15:56:54 -0300
commiteb30277a219f9ba37469f718cb7d1e5a72920e2b (patch)
treee118c9021a7a7f0ddb9839f39ff1e77c1d5aeb8c
parentd0bebae43029919737ed37d47b268e0c6d69e95a (diff)
downloadaports-eb30277a219f9ba37469f718cb7d1e5a72920e2b.tar.bz2
aports-eb30277a219f9ba37469f718cb7d1e5a72920e2b.tar.xz
testing/libva-utils: upgrade to 2.4.1
-rw-r--r--testing/libva-utils/APKBUILD40
1 files changed, 23 insertions, 17 deletions
diff --git a/testing/libva-utils/APKBUILD b/testing/libva-utils/APKBUILD
index 34b074a53b..7e195d6843 100644
--- a/testing/libva-utils/APKBUILD
+++ b/testing/libva-utils/APKBUILD
@@ -1,35 +1,41 @@
# Contributor: Taner Tas <taner76@gmail.com>
# Maintainer: Taner Tas <taner76@gmail.com>
pkgname=libva-utils
-pkgver=2.2.0
+pkgver=2.4.1
pkgrel=0
pkgdesc="Intel VA-API Media Applications and Scripts for libva"
+options="!check" # Most tests fail
url="https://github.com/01org/libva-utils"
arch="all"
license="MIT"
-makedepends="mesa-dev libva-dev autoconf automake libtool"
-source="https://github.com/01org/libva-utils/releases/download/$pkgver/$pkgname-$pkgver.tar.bz2"
-options="!check"
+makedepends="
+ meson
+ libva-dev
+ libdrm-dev
+ libx11-dev
+ libxext-dev
+ libxfixes-dev
+ wayland-dev
+ "
+source="$pkgname-$pkgver.tar.gz::https://github.com/intel/libva-utils/archive/$pkgver.tar.gz"
build() {
- ./autogen.sh \
- --build=$CBUILD \
- --host=$CHOST \
+ meson \
--prefix=/usr \
- --disable-wayland \
--sysconfdir=/etc \
- --mandir=/usr/share/man \
--localstatedir=/var \
- --disable-nls
- make
-}
-
-check() {
- make check
+ --libdir=/usr/lib \
+ --buildtype=release \
+ -Ddrm=true \
+ -Dx11=true \
+ -Dwayland=true \
+ -Dtests=false \
+ . output
+ ninja -C output
}
package() {
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" ninja -C output install
}
-sha512sums="bd1a6e4fa72379b6b2ac44c00fb1813447a6b44b2bbb08df5158ddc9dc36b3cb774b3caf4e7e3813edbb01cbe4dab1683185d921fdfbc2a3f1cef0057912df80 libva-utils-2.2.0.tar.bz2"
+sha512sums="dbd21039caa5496eedc491eee7a1bfe93bcc85a60468eadcbb93d8efb30457ac7ecc28b59b303db6711bdbb82903e5db3759424404aaa1269a41ca34e6965f18 libva-utils-2.4.1.tar.gz"