aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2016-07-05 12:09:29 +0000
committerTimo Teräs <timo.teras@iki.fi>2016-07-06 10:29:54 +0000
commiteb4fa0769592ff82e390bc60e408163dbbd93eeb (patch)
tree9108b8383167bd3e5ed55f549ddb10fcd19690d2
parent658ce467c6b897f1ad5e3b90df18444e34cc9bdf (diff)
downloadaports-eb4fa0769592ff82e390bc60e408163dbbd93eeb.tar.bz2
aports-eb4fa0769592ff82e390bc60e408163dbbd93eeb.tar.xz
main/libtool: fix a cross compile issue
-rw-r--r--main/libtool/APKBUILD25
-rw-r--r--main/libtool/libtool-fix-cross-compile.patch36
2 files changed, 50 insertions, 11 deletions
diff --git a/main/libtool/APKBUILD b/main/libtool/APKBUILD
index 9d07b377f4..9a40ee70de 100644
--- a/main/libtool/APKBUILD
+++ b/main/libtool/APKBUILD
@@ -1,23 +1,23 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libtool
pkgver=2.4.6
-pkgrel=0
+pkgrel=1
pkgdesc="A generic library support script"
arch="all"
license='GPL'
url="http://www.gnu.org/software/libtool"
-source="ftp://ftp.gnu.org/pub/gnu/libtool/${pkgname}-${pkgver}.tar.gz"
+source="ftp://ftp.gnu.org/pub/gnu/libtool/${pkgname}-${pkgver}.tar.gz
+ libtool-fix-cross-compile.patch
+ "
depends="bash libltdl"
-makedepends="m4"
+makedepends="m4 help2man"
subpackages="libltdl $pkgname-doc"
options="libtool"
-prepare() {
- cd "$srcdir"/$pkgname-$pkgver
-}
+builddir="$srcdir"/$pkgname-$pkgver
build() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -28,7 +28,7 @@ build() {
}
package() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$builddir"
make DESTDIR="$pkgdir" install
}
@@ -39,6 +39,9 @@ libltdl() {
mv "$pkgdir/usr/lib/libltdl.so"* "$subpkgdir/usr/lib/"
}
-md5sums="addf44b646ddb4e3919805aa88fa7c5e libtool-2.4.6.tar.gz"
-sha256sums="e3bd4d5d3d025a36c21dd6af7ea818a2afcd4dfc1ea5a17b39d7854bcd0c06e3 libtool-2.4.6.tar.gz"
-sha512sums="3233d81cb2739a54b840a0a82064eebbfaa4fb442fb993a35d6bd41d8395c51f038c90ae048b9252f172d0a5bbfb4b36e2b13d4477001f9ff7d4124237819a18 libtool-2.4.6.tar.gz"
+md5sums="addf44b646ddb4e3919805aa88fa7c5e libtool-2.4.6.tar.gz
+3657a65e226879586c29360eac6ae41b libtool-fix-cross-compile.patch"
+sha256sums="e3bd4d5d3d025a36c21dd6af7ea818a2afcd4dfc1ea5a17b39d7854bcd0c06e3 libtool-2.4.6.tar.gz
+c98362e9b1efd90618813a6901144452dc03f51e6300686bb07e068ac851c245 libtool-fix-cross-compile.patch"
+sha512sums="3233d81cb2739a54b840a0a82064eebbfaa4fb442fb993a35d6bd41d8395c51f038c90ae048b9252f172d0a5bbfb4b36e2b13d4477001f9ff7d4124237819a18 libtool-2.4.6.tar.gz
+aa14cadd70a633520249fa3a6a4c45b309a980380e62dd5982b3ae842c478a77401ad809297fceebd167c167b0a19f380e6a6c295bc75d1029d56d3bf262b209 libtool-fix-cross-compile.patch"
diff --git a/main/libtool/libtool-fix-cross-compile.patch b/main/libtool/libtool-fix-cross-compile.patch
new file mode 100644
index 0000000000..585897e0de
--- /dev/null
+++ b/main/libtool/libtool-fix-cross-compile.patch
@@ -0,0 +1,36 @@
+--- libtool-2.4.6.orig/build-aux/ltmain.in
++++ libtool-2.4.6/build-aux/ltmain.in
+@@ -6449,7 +6449,7 @@
+ fi
+ else
+ # We cannot seem to hardcode it, guess we'll fake it.
+- add_dir=-L$libdir
++ add_dir="-L$lt_sysroot$libdir"
+ # Try looking first in the location we're being installed to.
+ if test -n "$inst_prefix_dir"; then
+ case $libdir in
+@@ -7628,9 +7628,11 @@
+ test relink = "$opt_mode" || rpath=$compile_rpath$rpath
+ for libdir in $rpath; do
+ if test -n "$hardcode_libdir_flag_spec"; then
++ func_replace_sysroot "$libdir"
++ libdir=$func_replace_sysroot_result
++ func_stripname '=' '' "$libdir"
++ libdir=$func_stripname_result
+ if test -n "$hardcode_libdir_separator"; then
+- func_replace_sysroot "$libdir"
+- libdir=$func_replace_sysroot_result
+ if test -z "$hardcode_libdirs"; then
+ hardcode_libdirs=$libdir
+ else
+@@ -8360,6 +8362,10 @@
+ hardcode_libdirs=
+ for libdir in $compile_rpath $finalize_rpath; do
+ if test -n "$hardcode_libdir_flag_spec"; then
++ func_replace_sysroot "$libdir"
++ libdir=$func_replace_sysroot_result
++ func_stripname '=' '' "$libdir"
++ libdir=$func_stripname_result
+ if test -n "$hardcode_libdir_separator"; then
+ if test -z "$hardcode_libdirs"; then
+ hardcode_libdirs=$libdir