aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-06-01 22:07:28 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-06-19 21:18:38 -0300
commiteb5068d29db2a63d4be5c70488932666e13afaba (patch)
treecc7d68a48cab0829bd4d318a4808bfae17585f67
parenta4cf08a43f8d780ed6660632c2f22acc4e842ac8 (diff)
downloadaports-eb5068d29db2a63d4be5c70488932666e13afaba.tar.bz2
aports-eb5068d29db2a63d4be5c70488932666e13afaba.tar.xz
testing/kwayland-integration: new aport
-rw-r--r--testing/kwayland-integration/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/testing/kwayland-integration/APKBUILD b/testing/kwayland-integration/APKBUILD
new file mode 100644
index 0000000000..cd5c6f0d2c
--- /dev/null
+++ b/testing/kwayland-integration/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Bhushan Shah <bshah@kde.org>
+# Maintainer: Bhushan Shah <bshah@kde.org>
+pkgname=kwayland-integration
+pkgver=5.16.1
+pkgrel=0
+pkgdesc="KWayland integration"
+url="https://www.kde.org/workspaces/plasmadesktop/"
+arch="all"
+license="LGPL-2.1-only OR LGPL-3.0-only"
+depends="kwayland kglobalaccel kidletime"
+makedepends="cmake extra-cmake-modules qt5-qtbase-dev kwayland-dev kwindowsystem-dev kidletime-dev"
+source="https://download.kde.org/stable/plasma/$pkgver/$pkgname-$pkgver.tar.xz"
+options="!check" # Broken
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="cde816e04944cd262ab6b154672b54c0d736b366b47666930d3c83c9a6ef47067dbf0407cbc84a3a51cc9a2fe31f338bfe1f2d231e94ecbacd2f2403b9a5dea9 kwayland-integration-5.16.1.tar.xz"