aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorIsaac Dunham <ibid.ag@gmail.com>2016-05-08 21:36:26 -0700
committerNatanael Copa <ncopa@alpinelinux.org>2016-05-09 16:09:15 +0000
commiteb85c62dec5350297acc131e3ce559d30197b4eb (patch)
tree5a2cf7775ab0675b6c07141782ef451e7883af62
parent1a4f742d2474ad662c2f90e041ff046cc0c83fcf (diff)
downloadaports-eb85c62dec5350297acc131e3ce559d30197b4eb.tar.bz2
aports-eb85c62dec5350297acc131e3ce559d30197b4eb.tar.xz
community/sword: fix superscripts in OSIS->xhtml translation
Pick up a fix from SVN, since the next release is not happening before I leave. (This bug messes up display of an apparatus in Xiphos.)
-rw-r--r--community/sword/01-osisxhtml-super.patch16
-rw-r--r--community/sword/APKBUILD12
2 files changed, 24 insertions, 4 deletions
diff --git a/community/sword/01-osisxhtml-super.patch b/community/sword/01-osisxhtml-super.patch
new file mode 100644
index 0000000000..dec1de72ee
--- /dev/null
+++ b/community/sword/01-osisxhtml-super.patch
@@ -0,0 +1,16 @@
+Fix superscripts in OSIS->xhtml translations, based on a fix
+by Karl Kleinpaste (revision 3375 in SVN)
+
+diff --git a/src/modules/filters/osisxhtml.cpp b/src/modules/filters/osisxhtml.cpp
+index fb743e2..759acc4 100644
+--- a/src/modules/filters/osisxhtml.cpp
++++ b/src/modules/filters/osisxhtml.cpp
+@@ -617,7 +617,7 @@ bool OSISXHTML::handleToken(SWBuf &buf, const char *token, BasicFilterUserData *
+ else if (type == "ol") {
+ outText("</span>", buf, u);
+ }
+- else if (type == "sup") {
++ else if (type == "super") {
+ outText("</sup>", buf, u);
+ }
+ else if (type == "sub") {
diff --git a/community/sword/APKBUILD b/community/sword/APKBUILD
index 44e123d46e..7572080125 100644
--- a/community/sword/APKBUILD
+++ b/community/sword/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Isaac Dunham <ibid.ag@gmail.com>
pkgname=sword
pkgver=1.7.4
-pkgrel=4
+pkgrel=5
pkgdesc="Library for free Bible software"
url="http://www.crosswire.org/sword/"
arch="all"
@@ -23,6 +23,7 @@ install="$pkgname.pre-install"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang $pkgname-utils"
source="http://www.crosswire.org/ftpmirror/pub/sword/source/v1.7/sword-$pkgver.tar.gz
00-fflush.patch
+ 01-osisxhtml-super.patch
"
_builddir="$srcdir"/sword-$pkgver
@@ -80,8 +81,11 @@ utils() {
}
md5sums="1677f02a86cbf07713d4e1d4c39791e6 sword-1.7.4.tar.gz
-cce51448f99b7253a502266e268386b6 00-fflush.patch"
+cce51448f99b7253a502266e268386b6 00-fflush.patch
+2c69162d27a1cf3e1832c6efc4749b63 01-osisxhtml-super.patch"
sha256sums="995da8cf5a207c1f09809bf4b9db0bd7d267da5fcdb9d6666c9b313edd9d213d sword-1.7.4.tar.gz
-4c6000d94428cb5150b7debc5a180c17e455ba718b6ef54fa937e9bb4f8c1b80 00-fflush.patch"
+4c6000d94428cb5150b7debc5a180c17e455ba718b6ef54fa937e9bb4f8c1b80 00-fflush.patch
+02c944ad03636dc8cc716a5aeb5e14ef4f767cc8cbb131dbd2d4e65c31a45071 01-osisxhtml-super.patch"
sha512sums="4c8b183e613367364439cc7a8a842012f75180fccc8eb775b9af2dc4c10f39c152261d35f0aadaaa91a11df36ab1a4057c2edc50ea4b0b3bb0ab0a847ff68f75 sword-1.7.4.tar.gz
-6f6c13e7d04458e73d36c114017ad9e76e04c991adb8e457a0b55ce09fcaa95f33b2c26b73c2fd28591f07b69d3d03c1db6d08676001b3a45e0b66b22cb47dc0 00-fflush.patch"
+6f6c13e7d04458e73d36c114017ad9e76e04c991adb8e457a0b55ce09fcaa95f33b2c26b73c2fd28591f07b69d3d03c1db6d08676001b3a45e0b66b22cb47dc0 00-fflush.patch
+98490104a0ef91497a3add3f078158b6fa57c73fc4028f26392716a0efb0957fd029a25239e04a2aa11ebd80583a23a9520a34d18bbf05ff54511d10bdd22bbe 01-osisxhtml-super.patch"