aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-12-10 10:08:29 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-12-10 10:14:50 +0100
commitebc8b448ce5bb8f6feebd134272baa01cb27e538 (patch)
tree615cc004e512e75742544e4e507d5f44c0fea126
parentad3b4eb0e296121f9995e4d2146eab141d904242 (diff)
downloadaports-ebc8b448ce5bb8f6feebd134272baa01cb27e538.tar.bz2
aports-ebc8b448ce5bb8f6feebd134272baa01cb27e538.tar.xz
testing/pulseaudio-ctl: new aport
https://github.com/graysky2/pulseaudio-ctl Control pulseaudio volume from the shell or mapped to keyboard shortcuts
-rw-r--r--testing/pulseaudio-ctl/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/testing/pulseaudio-ctl/APKBUILD b/testing/pulseaudio-ctl/APKBUILD
new file mode 100644
index 0000000000..07c72f5ed2
--- /dev/null
+++ b/testing/pulseaudio-ctl/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=pulseaudio-ctl
+pkgver=1.67
+pkgrel=0
+pkgdesc="Control pulseaudio volume from the shell or mapped to keyboard shortcuts"
+options="!check" # No testsuite
+url="https://github.com/graysky2/pulseaudio-ctl"
+arch="noarch"
+license="MIT"
+depends="bash pulseaudio-utils"
+subpackages="
+ $pkgname-doc
+ $pkgname-zsh-completion:zshcomp:noarch
+ "
+source="$pkgname-$pkgver.tar.gz::https://github.com/graysky2/pulseaudio-ctl/archive/v$pkgver.tar.gz"
+
+build() {
+ make
+}
+
+package() {
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+}
+
+zshcomp() {
+ depends=""
+ pkgdesc="Zsh compltions for $pkgname"
+ install_if="$pkgname=$pkgver-r$pkgrel zsh"
+
+ mkdir -p "$subpkgdir"/usr/share/zsh
+ mv "$pkgdir"/usr/share/zsh/site-functions "$subpkgdir"/usr/share/zsh
+ rmdir -p "$pkgdir"/usr/share/zsh 2>/dev/null || :
+}
+
+sha512sums="5ea1cbfd87cf073de46b6fd9953a3c7b9c6969da46103dd5dfc56aa3f179b2ba36ade5db7ca47d204f0f60ac02020f1a4f2dd58bbaf010f9a99780702295418c pulseaudio-ctl-1.67.tar.gz"