aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-21 16:05:05 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-21 16:05:05 -0300
commitebccfc7db415f96b008e9b15b0f7b4f0c0b5b91d (patch)
tree89ba912169fb68e3562101bf1a0fe77fa888dbac
parent746645592a9d6e4c73c4059d1cf4d974d4397d69 (diff)
downloadaports-ebccfc7db415f96b008e9b15b0f7b4f0c0b5b91d.tar.bz2
aports-ebccfc7db415f96b008e9b15b0f7b4f0c0b5b91d.tar.xz
testing/unclutter-xfixes: upgrade to 1.5
-rw-r--r--testing/unclutter-xfixes/APKBUILD24
1 files changed, 8 insertions, 16 deletions
diff --git a/testing/unclutter-xfixes/APKBUILD b/testing/unclutter-xfixes/APKBUILD
index 61c291918f..580e5349a5 100644
--- a/testing/unclutter-xfixes/APKBUILD
+++ b/testing/unclutter-xfixes/APKBUILD
@@ -1,32 +1,24 @@
# Contributor: Michael Pirogov <vbnet.ru@gmail.com>
# Maintainer: Michael Pirogov <vbnet.ru@gmail.com>
pkgname=unclutter-xfixes
-pkgver=1.2
+pkgver=1.5
pkgrel=0
-url="https://github.com/Airblader/${pkgname}"
+url="https://github.com/Airblader/$pkgname"
arch="all"
license="MIT"
pkgdesc="Hides mouse pointer while not in use"
makedepends="libxfixes-dev libev-dev libxi-dev asciidoc"
-subpackages="${pkgname}-doc"
-_myver="${pkgname}-${pkgver}"
-source="${_myver}.tar.gz::https://github.com/Airblader/${pkgname}/archive/v${pkgver}.tar.gz"
-builddir="${srcdir}/${pkgname}-${pkgver}"
+subpackages="$pkgname-doc"
+_myver="$pkgname-$pkgver"
+source="$_myver.tar.gz::https://github.com/Airblader/$pkgname/archive/v$pkgver.tar.gz"
build() {
- cd "${builddir}"
make
}
-check() {
- cd "${builddir}"
- ./unclutter -v
-}
-
package() {
- cd "${builddir}"
- install -D -m755 "${builddir}/unclutter" "${pkgdir}/usr/bin/${pkgname}"
- install -D -m444 "${builddir}/man/${pkgname}.1" "${pkgdir}/usr/share/man/man1/${pkgname}.1"
+ install -D -m755 "$builddir/unclutter" "$pkgdir/usr/bin/$pkgname"
+ install -D -m444 "$builddir/man/$pkgname.1" "$pkgdir/usr/share/man/man1/$pkgname.1"
}
-sha512sums="59df9e0dcf917f83b11ce85ba3d7445234ed6e63fc060d5158a9278821fc01c7b0f1f1178ad41e6307d7e0e8dd0ae850dc8bb7a613949deb10496535058fe5e9 unclutter-xfixes-1.2.tar.gz"
+sha512sums="0b8823d5ab64193f7e5fe03ceecbe0f475bbe36f78c4a0295705a80e9df1e5a8c4f65eb749b55e5b8b06aa3248e4f2fc1daac1b14b84aab157bdfbff39bba095 unclutter-xfixes-1.5.tar.gz"