aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimothy Legge <timlegge@gmail.com>2019-11-29 02:46:49 +0000
committerLeo <thinkabit.ukim@gmail.com>2019-11-29 23:50:03 +0100
commitee87878e9e50de04e77ca0b75b1a1a4f70c8096c (patch)
treee06882d0babcd5da2e581f6b3779814f3273e0c7
parentbae2e6540c3af515aea6a9422cb0bf316dc12020 (diff)
downloadaports-ee87878e9e50de04e77ca0b75b1a1a4f70c8096c.tar.bz2
aports-ee87878e9e50de04e77ca0b75b1a1a4f70c8096c.tar.xz
testing/odt2txt: new aport
-rw-r--r--testing/odt2txt/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/odt2txt/APKBUILD b/testing/odt2txt/APKBUILD
new file mode 100644
index 0000000000..96e20be283
--- /dev/null
+++ b/testing/odt2txt/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Timothy Legge <timlegge@gmail.com>
+# Maintainer: Timothy Legge <timlegge@gmail.com>
+pkgname=odt2txt
+pkgver=0.5_git20170928
+pkgrel=0
+pkgdesc="extracts the text out of OpenDocument Texts"
+url="https://github.com/dstosberg/odt2txt/"
+arch="x86_64"
+license="GPL-2.0-only"
+_commit="56b945e7304b899db78a658cc7c60a3c9afd984d"
+source="$pkgname.zip::https://github.com/dstosberg/odt2txt/archive/$_commit.zip"
+builddir="$srcdir/$pkgname-$_commit"
+makedepends="zlib-dev libzip-dev make"
+subpackages="$pkgname-doc"
+
+# No checks are available in the source package
+options="!check"
+
+build() {
+ make
+}
+
+package() {
+ install -Dm755 odt2txt "$pkgdir"/usr/bin/odt2txt
+ install -Dm644 odt2txt.1 "$pkgdir"/usr/share/man/man1/odt2txt.1
+}
+
+sha512sums="bff0e0903b4e6d04784bb4a4f6375d32c67bc9695fd83f0974cc53cef414e25b385b92f56467d41a66e8cf9fe4c85f23f5b99c7cf01f11f4b32741f1b4e43d43 odt2txt.zip"