aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2019-04-03 16:27:09 -0400
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-04-05 11:55:29 +0000
commitf359f656d8df48f0b50f264a5450379cc923c8eb (patch)
tree6e6b76e70a1b273906d35510b521a08aa7b59f92
parentda401360fc7b202864d280918f27cb65d49bd91c (diff)
downloadaports-f359f656d8df48f0b50f264a5450379cc923c8eb.tar.bz2
aports-f359f656d8df48f0b50f264a5450379cc923c8eb.tar.xz
testing/py-hypothesis: update to 4.14.3
-rw-r--r--testing/py-hypothesis/APKBUILD20
1 files changed, 12 insertions, 8 deletions
diff --git a/testing/py-hypothesis/APKBUILD b/testing/py-hypothesis/APKBUILD
index c87eeecf64..783aaab202 100644
--- a/testing/py-hypothesis/APKBUILD
+++ b/testing/py-hypothesis/APKBUILD
@@ -1,17 +1,21 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=py-hypothesis
-pkgver=3.38.0
-pkgrel=1
+pkgver=4.14.3
+pkgrel=0
pkgdesc="Advanced property-based (QuickCheck-like) testing for Python"
url="http://hypothesis.works/"
arch="noarch"
license="MPL-2.0"
-depends=""
-makedepends="py-setuptools python2-dev python3-dev py-enum34"
-install=""
+depends="py-coverage"
+_py2_deps="py2-coverage"
+_py3_deps="py3-coverage"
+makedepends="
+ $_py2_deps $_py3_deps python2-dev python3-dev py2-setuptools py3-setuptools
+ py-enum34
+"
subpackages="py2-hypothesis:_py py3-hypothesis:_py"
-source="py-hypothesis-$pkgver.tar.gz::https://github.com/HypothesisWorks/hypothesis-python/archive/$pkgver.tar.gz"
-builddir="$srcdir/hypothesis-python-$pkgver"
+source="py-hypothesis-$pkgver.tar.gz::https://github.com/HypothesisWorks/hypothesis-python/archive/hypothesis-python-$pkgver.tar.gz"
+builddir="$srcdir/hypothesis-hypothesis-python-$pkgver/hypothesis-python"
build() {
cd "$builddir"
@@ -44,4 +48,4 @@ _py() {
mv "$pkgdir"/usr/lib/${python}* "$subpkgdir"/usr/lib/
}
-sha512sums="9001b045013f720885e53649c9445ac12c149e609b2532fc52ed2b4743aad59a2a59d6775988f65a23b58983a726849d75c368d291662c4b1d62e5d769efe88e py-hypothesis-3.38.0.tar.gz"
+sha512sums="56f0a796741b1a46bfe91e578dc76067b612d0041dd8b93043521c8e53827a5bcdd815f94e91d22d4ae9d13125bfb9012cb1c4660635e7cc93472141be504efb py-hypothesis-4.14.3.tar.gz"