aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2019-11-23 16:34:58 +0100
committerSören Tempel <soeren+git@soeren-tempel.net>2019-11-23 16:34:58 +0100
commitf3f167d15f703ebe0f9223065c4568b71373c578 (patch)
treea46689263b713165c9e8b55b85b8e6f4a1bb412e
parenta740bb96073eeb13142d9dffefa3093e644d7c0d (diff)
downloadaports-f3f167d15f703ebe0f9223065c4568b71373c578.tar.bz2
aports-f3f167d15f703ebe0f9223065c4568b71373c578.tar.xz
community/z3: attempt to fix build on some architectures
-rw-r--r--community/z3/0001-Fix-fail-to-build-on-clang-and-g.patch24
-rw-r--r--community/z3/APKBUILD6
2 files changed, 28 insertions, 2 deletions
diff --git a/community/z3/0001-Fix-fail-to-build-on-clang-and-g.patch b/community/z3/0001-Fix-fail-to-build-on-clang-and-g.patch
new file mode 100644
index 0000000000..8edb6e5f23
--- /dev/null
+++ b/community/z3/0001-Fix-fail-to-build-on-clang-and-g.patch
@@ -0,0 +1,24 @@
+From 37431d6f12ba3c7f8a0f7f7eb21a67579544b1cc Mon Sep 17 00:00:00 2001
+From: Nikolaj Bjorner <nbjorner@microsoft.com>
+Date: Wed, 20 Nov 2019 15:01:04 -0800
+Subject: [PATCH] Fix fail to build on clang++ and g++
+
+Without this patch `src/util/mpz.cpp` fails to build when `__GNUC__` is
+defined.
+---
+ src/util/mpz.cpp | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/src/util/mpz.cpp b/src/util/mpz.cpp
+index a8190df1b..9c2d3d5ff 100644
+--- a/src/util/mpz.cpp
++++ b/src/util/mpz.cpp
+@@ -72,6 +72,8 @@ inline uint64_t _trailing_zeros64(uint64_t x) {
+
+ #if defined(_WINDOWS) && !defined(_M_ARM) && !defined(_M_ARM64)
+ // _trailing_zeros32 already defined using intrinsics
++#elif defined(__GNUC__)
++// _trailing_zeros32 already defined using intrinsics
+ #else
+ inline uint32_t _trailing_zeros32(uint32_t x) {
+ uint32_t r = 0;
diff --git a/community/z3/APKBUILD b/community/z3/APKBUILD
index 1083ce66fe..373b8edfae 100644
--- a/community/z3/APKBUILD
+++ b/community/z3/APKBUILD
@@ -9,7 +9,8 @@ arch="all !s390x !aarch64"
license="MIT"
makedepends="cmake python3"
subpackages="$pkgname-dev py3-$pkgname:py3:noarch"
-source="https://github.com/Z3Prover/z3/archive/z3-$pkgver.tar.gz"
+source="https://github.com/Z3Prover/z3/archive/z3-$pkgver.tar.gz
+ 0001-Fix-fail-to-build-on-clang-and-g.patch"
builddir="$srcdir/z3-z3-$pkgver"
build() {
@@ -49,4 +50,5 @@ py3() {
"$subpkgdir"/usr/lib/
}
-sha512sums="145e2b2f1fa4edd0917107c7e1d54d779c7ed85c48af2ce6def4c90d1c4db05f74c9657e173cedf48770589fbe484c97fa1923295271cd3792523ffc4f67ed0c z3-4.8.7.tar.gz"
+sha512sums="145e2b2f1fa4edd0917107c7e1d54d779c7ed85c48af2ce6def4c90d1c4db05f74c9657e173cedf48770589fbe484c97fa1923295271cd3792523ffc4f67ed0c z3-4.8.7.tar.gz
+4463b00e84d81447e62f6363163e6a2fa072fe1a1e1bab29c966ae00a222ab1a2e7429b6527bc5d81defb376590dca7bbc06b970fa780d77384011b573ffd7fd 0001-Fix-fail-to-build-on-clang-and-g.patch"