aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2020-05-12 08:51:48 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2020-05-12 08:55:05 +0000
commitfac4b2f5a7b617e8d570f01fd7b72ef87208eb80 (patch)
tree9ef4211036f8b69bf4cdd828f09d6d45e511b551
parent2aed85e1bc8e1b87eee6f5d94e2f86a40f27620e (diff)
downloadaports-fac4b2f5a7b617e8d570f01fd7b72ef87208eb80.tar.bz2
aports-fac4b2f5a7b617e8d570f01fd7b72ef87208eb80.tar.xz
main/patchwork: remove meaningless -postgresql subpackage
remove -postgresql subpackage which only tried to pull in non-existing py-psycopg2 dependency, while py3-psycopg2 was explicitly installed by main package. also make the install_if for nginx uwsgi include the exact version of patchwork to avoid chaos in case multiple versions of patchwork exists in repository.
-rw-r--r--community/patchwork/APKBUILD11
1 files changed, 2 insertions, 9 deletions
diff --git a/community/patchwork/APKBUILD b/community/patchwork/APKBUILD
index 9783668cda..023963ba47 100644
--- a/community/patchwork/APKBUILD
+++ b/community/patchwork/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=patchwork
pkgver=2.1.5
-pkgrel=0
+pkgrel=1
pkgdesc="Web-based patch tracking system"
url="https://github.com/getpatchwork/patchwork"
arch="noarch"
@@ -19,7 +19,6 @@ subpackages="
$pkgname-doc
$pkgname-uwsgi-apache2:apache2_wsgi
$pkgname-uwsgi-nginx:nginx_wsgi
- $pkgname-postgresql
pwclient:pwclient
"
source="patchwork-$pkgver.tar.gz::https://github.com/getpatchwork/patchwork/archive/v$pkgver.tar.gz
@@ -61,19 +60,13 @@ nginx_wsgi() {
pkgdesc="$pkgname nginx wsgi support"
depends="nginx uwsgi-python"
replaces="$pkgname-nginx_wsgi"
- install_if="nginx patchwork uwsgi"
+ install_if="$pkgname=$pkgver-r$pkgrel nginx uwsgi"
install -Dm644 "$srcdir"/nginx-patchwork.conf \
"$subpkgdir"/etc/nginx/conf.d/patchwork.conf
install -Dm644 "$srcdir"/nginx-uwsgi-patchwork-conf.ini \
"$subpkgdir"/etc/uwsgi/conf.d/patchwork.ini
}
-postgresql() {
- pkgdesc="$pkgname postgresql support"
- depends="py-psycopg2"
- mkdir -p "$subpkgdir"
-}
-
pwclient() {
pkgdesc="command-line client for patchwork"
depends="python3"