aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortmpfile <tmpfile@users.noreply.github.com>2017-09-06 10:38:28 -0300
committerTimo Teräs <timo.teras@iki.fi>2017-09-07 07:59:17 +0000
commitfc4fa9bb9198547327849d8ad33706f94be231d6 (patch)
tree288364e9327796f7f6d5a98127db89998192b1ce
parent55018d4a38cf88588db244133dce56de10223736 (diff)
downloadaports-fc4fa9bb9198547327849d8ad33706f94be231d6.tar.bz2
aports-fc4fa9bb9198547327849d8ad33706f94be231d6.tar.xz
main/audacious: upgrade to 3.9
-rw-r--r--main/audacious/APKBUILD33
1 files changed, 10 insertions, 23 deletions
diff --git a/main/audacious/APKBUILD b/main/audacious/APKBUILD
index 6ac64427da..5a8aa95915 100644
--- a/main/audacious/APKBUILD
+++ b/main/audacious/APKBUILD
@@ -2,52 +2,39 @@
# Contributor: William Pitcock <nenolod@dereferenced.org>
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname=audacious
-pkgver=3.8.2
+pkgver=3.9
pkgrel=0
pkgdesc="A playlist-oriented media player with multiple interfaces"
url="http://audacious-media-player.org/"
arch="all"
license="ISC"
-depends=""
depends_dev="gtk+2.0-dev dbus-glib-dev"
makedepends="$depends_dev libguess-dev>=1.2 libxml2-dev autoconf automake"
-install=
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang $pkgname-dbg"
source="http://distfiles.audacious-media-player.org/$pkgname-$pkgver.tar.bz2"
+builddir="$srcdir/$pkgname-$pkgver"
-_builddir="$srcdir"/$pkgname-$pkgver
prepare() {
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch)
- msg "Applying $i..."
- patch -s -p1 -N -i "$srcdir"/$i || return 1
- ;;
- esac
- done
-
+ default_prepare
msg "Rebuilding configure..."
- aclocal -I m4 && autoheader && autoconf || return 1
+ aclocal -I m4 && autoheader && autoconf
}
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
- --enable-chardet \
- || return 1
- make || return 1
- return 0
+ --enable-chardet
+ make
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
}
-sha512sums="13914d837ab5f283c45297424033486d9a5158f78f17f5538ecce780125fa76585e9e45852d15f6ecf3ed974e7a2f6289ceaaeffa97b2ea79b2bef449d8c786b audacious-3.8.2.tar.bz2"
+sha512sums="d8ef24c91c84bfa80831075cd9a12fc4bf02cec8bc96bcfa5a941254d194cccdc482482b1c015bc63e1142718c2221034c0f3a87e2cb6e4daf3b4cc428328aaa audacious-3.9.tar.bz2"