aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorwener <wenermail@gmail.com>2019-06-28 03:45:40 +0800
committerNatanael Copa <ncopa@alpinelinux.org>2019-07-04 06:59:51 +0000
commitfdcf47558b7e4df5e31c468cfacc30515f993b6a (patch)
treedd2af189991abf549cd6080f54bc6e0b0635b267
parentb8143dc573079145ce484a52ae9beac9645d98d4 (diff)
downloadaports-fdcf47558b7e4df5e31c468cfacc30515f993b6a.tar.bz2
aports-fdcf47558b7e4df5e31c468cfacc30515f993b6a.tar.xz
main/protobuf: upgrade to 3.8.0
-rw-r--r--main/protobuf/APKBUILD18
-rw-r--r--main/protobuf/trim-rakefile.patch14
2 files changed, 17 insertions, 15 deletions
diff --git a/main/protobuf/APKBUILD b/main/protobuf/APKBUILD
index 62fc04e984..a5b8ebb948 100644
--- a/main/protobuf/APKBUILD
+++ b/main/protobuf/APKBUILD
@@ -2,9 +2,9 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=protobuf
_gemname=google-protobuf
-pkgver=3.6.1
-_tstver=1.8.0
-pkgrel=1
+pkgver=3.8.0
+_tstver=5ec7f0c4a113e2f18ac2c6cc7df51ad6afc24081
+pkgrel=0
pkgdesc="Library for extensible, efficient structure packing"
url="https://github.com/google/protobuf"
arch="all"
@@ -12,8 +12,10 @@ license="BSD-3-Clause"
depends_dev="zlib-dev"
makedepends="$depends_dev autoconf automake libtool ruby ruby-dev ruby-rake"
subpackages="ruby-$_gemname:_ruby $pkgname-dev $pkgname-vim::noarch"
+# googletest 1.8 is not enought for protobuf
+# https://github.com/google/googletest/issues/2267
source="$pkgname-$pkgver.tar.gz::https://github.com/google/$pkgname/archive/v$pkgver.tar.gz
- googletest-$_tstver.tar.gz::https://github.com/google/googletest/archive/release-$_tstver.tar.gz
+ googletest-$_tstver.tar.gz::https://github.com/google/googletest/archive/$_tstver.tar.gz
musl-fix.patch
trim-rakefile.patch
"
@@ -27,7 +29,7 @@ prepare() {
# symlink tests to the test directory
rm -rf third_party/*
- ln -sf "$srcdir"/googletest-release-$_tstver \
+ ln -sf "$srcdir"/googletest-$_tstver \
"$builddir"/third_party/googletest
}
@@ -103,7 +105,7 @@ vim() {
"$subpkgdir"/usr/share/vim/vimfiles/syntax/proto.vim
}
-sha512sums="1bc175d24b49de1b1e41eaf39598194e583afffb924c86c8d2e569d935af21874be76b2cbd4d9655a1d38bac3d4cd811de88bc2c72d81bad79115e69e5b0d839 protobuf-3.6.1.tar.gz
-1dbece324473e53a83a60601b02c92c089f5d314761351974e097b2cf4d24af4296f9eb8653b6b03b1e363d9c5f793897acae1f0c7ac40149216035c4d395d9d googletest-1.8.0.tar.gz
+sha512sums="ba27c64e5193cd4a144bf0c9dc0d195fbbe6e580aaca01960362f0f185074588ca40046d3bcea76e1deae7508b722f6c5be484ea957122ae8e98229c7c3a4ad2 protobuf-3.8.0.tar.gz
+623b077b3334958fafcbc34aa85891883277994af33be530efd903f47738a3e3562001cbf3b6da1a5e7d03803c5bd51bcc1fab81490db85d5a4f2b15e7de1495 googletest-5ec7f0c4a113e2f18ac2c6cc7df51ad6afc24081.tar.gz
875592bc5dc5efe9087ea1b340673f54c984ecd5aa3b110a2da136bdc28009af7ce1a9c57f4747ff809fc02eb6c39a0209c277177172af467a54172d9700188a musl-fix.patch
-d1d11fe76d2a1ae92f47f9eb1e0d94c67b7192a9dc4a382b6c0835f4fe4dbc2f98ca1b3c5095ad5b4e368581072330f943209c0decea02ebb47938588543fdb1 trim-rakefile.patch"
+495ba43f1e43e49caee6f44bb7e8e1cc52d46b158b946598c2b296a9efa07fd9abadc8649c3751aad34d26380dcdef782239449cbc5fd7654df144d249dd9de2 trim-rakefile.patch"
diff --git a/main/protobuf/trim-rakefile.patch b/main/protobuf/trim-rakefile.patch
index 7f53d70992..497a92dde3 100644
--- a/main/protobuf/trim-rakefile.patch
+++ b/main/protobuf/trim-rakefile.patch
@@ -8,7 +8,7 @@ Remove code that we don't use to avoid installing additional dependencies.
require "rake/testtask"
spec = Gem::Specification.load("google-protobuf.gemspec")
-@@ -39,51 +37,6 @@
+@@ -39,51 +37,6 @@ unless ENV['IN_DOCKER'] == 'true'
end
end
@@ -43,13 +43,13 @@ Remove code that we don't use to avoid installing additional dependencies.
-
- task 'gem:windows' do
- require 'rake_compiler_dock'
-- RakeCompilerDock.sh "bundle && IN_DOCKER=true rake cross native gem RUBY_CC_VERSION=2.5.0:2.4.0:2.3.0:2.2.2:2.1.6:2.0.0"
+- RakeCompilerDock.sh "bundle && IN_DOCKER=true rake cross native gem RUBY_CC_VERSION=2.6.0:2.5.0:2.4.0:2.3.0"
- end
-
- if RUBY_PLATFORM =~ /darwin/
- task 'gem:native' do
- system "rake genproto"
-- system "rake cross native gem RUBY_CC_VERSION=2.5.0:2.4.0:2.3.0:2.2.2:2.1.6:2.0.0"
+- system "rake cross native gem RUBY_CC_VERSION=2.6.0:2.5.1:2.4.0:2.3.0"
- end
- else
- task 'gem:native' => [:genproto, 'gem:windows']
@@ -59,14 +59,14 @@ Remove code that we don't use to avoid installing additional dependencies.
-
# Proto for tests.
genproto_output << "tests/generated_code.rb"
- genproto_output << "tests/test_import.rb"
-@@ -104,9 +57,6 @@
+ genproto_output << "tests/generated_code_proto2.rb"
+@@ -134,9 +87,7 @@ task :genproto => genproto_output
task :clean do
sh "rm -f #{genproto_output.join(' ')}"
-end
--
+
-Gem::PackageTask.new(spec) do |pkg|
end
- Rake::TestTask.new(:test => :build) do |t|
+ Rake::TestTask.new(:test => :build) do |t| \ No newline at end of file