aboutsummaryrefslogtreecommitdiffstats
path: root/community/abduco
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2019-02-14 11:42:47 +0100
committerSören Tempel <soeren+git@soeren-tempel.net>2019-02-14 11:44:50 +0100
commit44994ea26adc664f39e61f7da9c78946990146e5 (patch)
treec2816bf9d1aa61ab50671926bdb3bee8212ef4ba /community/abduco
parenta615992799052b67915220640c0bdad9b21251b5 (diff)
downloadaports-44994ea26adc664f39e61f7da9c78946990146e5.tar.bz2
aports-44994ea26adc664f39e61f7da9c78946990146e5.tar.xz
community/abduco: move from testing
Diffstat (limited to 'community/abduco')
-rw-r--r--community/abduco/APKBUILD36
-rw-r--r--community/abduco/fix-tests.patch15
2 files changed, 51 insertions, 0 deletions
diff --git a/community/abduco/APKBUILD b/community/abduco/APKBUILD
new file mode 100644
index 0000000000..695ea9cf42
--- /dev/null
+++ b/community/abduco/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Maintainer: Drew DeVault <sir@cmpwn.com>
+pkgname=abduco
+pkgver=0.6
+pkgrel=2
+pkgdesc="Session management in a clean and simple way"
+url="http://www.brain-dump.org/projects/abduco/"
+arch="all"
+license="MIT"
+depends=""
+depends_dev=""
+makedepends=""
+install=""
+subpackages="$pkgname-doc"
+source="http://www.brain-dump.org/projects/$pkgname/$pkgname-$pkgver.tar.gz
+ fix-tests.patch"
+builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ make -C "$builddir"
+}
+
+check() {
+ cd "$builddir"
+ ./testsuite.sh
+}
+
+package() {
+ cd "$builddir"
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+ install -Dm644 README.md \
+ "$pkgdir"/usr/share/doc/$pkgname/README.md
+}
+
+sha512sums="3b70a5cc10f0a2743dcbdf6eebdcfcee0e4f4ff8c6ce0bf0aa9f55c3fa85ab43aa659997735e063eab36aba69f91be7bb5519f3f632bff1b9098f5179165c1f2 abduco-0.6.tar.gz
+0d9e5be04bfd9d0826c54d7a8ad8435dcd3559efd7eabca11ebab86f20acabd4d97e1c1fb81e895865e73034d4a2e278f409236f301a6d71ac907af66ced046b fix-tests.patch"
diff --git a/community/abduco/fix-tests.patch b/community/abduco/fix-tests.patch
new file mode 100644
index 0000000000..746e438eb1
--- /dev/null
+++ b/community/abduco/fix-tests.patch
@@ -0,0 +1,15 @@
+Without this change pgrep seems to return the PID of the abduco process
+spawned in the previous line because it may not be removed yet. Removing
+the pgrep invocation is not the best solution but good enough for now.
+
+diff -upr abduco-0.6.orig/testsuite.sh abduco-0.6/testsuite.sh
+--- abduco-0.6.orig/testsuite.sh 2019-02-14 11:33:19.521290879 +0100
++++ abduco-0.6/testsuite.sh 2019-02-14 11:33:29.361298623 +0100
+@@ -55,7 +55,6 @@ expected_abduco_detached_output() {
+
+ check_environment() {
+ [ "`$ABDUCO | wc -l`" -gt 1 ] && echo Abduco session exists && exit 1;
+- pgrep abduco && echo Abduco process exists && exit 1;
+ return 0;
+ }
+