aboutsummaryrefslogtreecommitdiffstats
path: root/community/alpine-desktop
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-10-06 09:03:26 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2015-10-06 09:03:26 +0200
commitbb1ab7a709ec0d38357b2df0b01f6f55c49baf7a (patch)
tree5028067fb38c0b4cef7a44dcf14a6906e3216242 /community/alpine-desktop
parentb0400c5d0f6d977b933403b426cca4ff66e2ffee (diff)
downloadaports-bb1ab7a709ec0d38357b2df0b01f6f55c49baf7a.tar.bz2
aports-bb1ab7a709ec0d38357b2df0b01f6f55c49baf7a.tar.xz
community/alpine-desktop: moved from main
Diffstat (limited to 'community/alpine-desktop')
-rw-r--r--community/alpine-desktop/APKBUILD48
-rw-r--r--community/alpine-desktop/alpine-desktop.post-install9
2 files changed, 57 insertions, 0 deletions
diff --git a/community/alpine-desktop/APKBUILD b/community/alpine-desktop/APKBUILD
new file mode 100644
index 0000000000..270d9fd8ce
--- /dev/null
+++ b/community/alpine-desktop/APKBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=alpine-desktop
+pkgver=2.5
+pkgrel=0
+pkgdesc="Meta package for Alpine Desktop"
+url="http://alpinelinux.org"
+arch="noarch"
+license="GPL"
+makedepends=""
+depends="
+ abiword
+ audacious
+ claws-mail
+ dhcpcd
+ dhcpcd-ui
+ evince
+ firefox
+ gnumeric
+ lxdm
+ ristretto
+ sudo
+ eudev
+ xf86-input-keyboard
+ xf86-input-mouse
+ xf86-video-vesa
+ xfce4
+ xorg-server
+ xscreensaver
+ "
+install=alpine-desktop.post-install
+subpackages=""
+source=""
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ return 0
+}
+
+build() {
+ return 0
+}
+
+package() {
+ mkdir -p "$pkgdir"
+ return 0
+}
+
+md5sums=
diff --git a/community/alpine-desktop/alpine-desktop.post-install b/community/alpine-desktop/alpine-desktop.post-install
new file mode 100644
index 0000000000..0b52acc598
--- /dev/null
+++ b/community/alpine-desktop/alpine-desktop.post-install
@@ -0,0 +1,9 @@
+#!/bin/sh
+
+# add mousedev to /etc/modules if not already there
+
+if ! grep -w -q ^mousedev /etc/modules; then
+ echo mousedev >> /etc/modules
+fi
+modprobe mousedev || true
+