aboutsummaryrefslogtreecommitdiffstats
path: root/community/audiocd-kio
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-11-12 13:51:30 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-11-12 10:48:38 -0300
commitb73b1e51f320e8763a715c4c38e9d07ab2ddcd63 (patch)
treee55d5626a55fcf5f49ba282dda5c79f0c89b8802 /community/audiocd-kio
parent0d70c9ca5781eee1e5ef6f881cce997b78621d24 (diff)
downloadaports-b73b1e51f320e8763a715c4c38e9d07ab2ddcd63.tar.bz2
aports-b73b1e51f320e8763a715c4c38e9d07ab2ddcd63.tar.xz
community/audiocd-kio: move from testing
Diffstat (limited to 'community/audiocd-kio')
-rw-r--r--community/audiocd-kio/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/community/audiocd-kio/APKBUILD b/community/audiocd-kio/APKBUILD
new file mode 100644
index 0000000000..985cd4f67c
--- /dev/null
+++ b/community/audiocd-kio/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=audiocd-kio
+pkgver=19.08.2
+pkgrel=0
+arch="all"
+url="https://www.kde.org/applications/multimedia/"
+pkgdesc="Kioslave for accessing audio CDs"
+license="GPL-2.0-or-later AND GFDL-1.2-only"
+makedepends="extra-cmake-modules qt5-qtbase-dev kconfig-dev ki18n-dev kdoctools-dev kio-dev kcmutils-dev libkcddb-dev libkcompactdisc-dev cdparanoia-dev flac-dev libvorbis-dev"
+source="https://download.kde.org/stable/applications/$pkgver/src/audiocd-kio-$pkgver.tar.xz"
+subpackages="$pkgname-doc $pkgname-lang"
+options="!check" # No tests
+
+prepare() {
+ default_prepare
+
+ mkdir "$builddir"/build
+}
+
+build() {
+ cd "$builddir"/build
+ cmake "$builddir" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+check() {
+ cd "$builddir"/build
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ cd "$builddir"/build
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="092804445af964c4b5199683421988f473706379a164e95b435a7493a14f2b5a12d3e990d3ec34d3a62ebd483372c1f46db764b0b7278ebff0df484113228c15 audiocd-kio-19.08.2.tar.xz"