aboutsummaryrefslogtreecommitdiffstats
path: root/community/botan
diff options
context:
space:
mode:
authortcely <tcely@users.noreply.github.com>2019-03-06 07:49:55 -0500
committerKevin Daudt <kdaudt@alpinelinux.org>2019-03-06 20:01:32 +0000
commitc5cf2a448a11da42366a5743b0f83fde1097438c (patch)
tree2a5c6d56de960a373509818f0417f8b0a2d097f6 /community/botan
parentb5524fa1bc85a5a7f3b56991d4aa7557294a0d1a (diff)
downloadaports-c5cf2a448a11da42366a5743b0f83fde1097438c.tar.bz2
aports-c5cf2a448a11da42366a5743b0f83fde1097438c.tar.xz
community/botan: move from testing
Diffstat (limited to 'community/botan')
-rw-r--r--community/botan/APKBUILD58
1 files changed, 58 insertions, 0 deletions
diff --git a/community/botan/APKBUILD b/community/botan/APKBUILD
new file mode 100644
index 0000000000..287b133090
--- /dev/null
+++ b/community/botan/APKBUILD
@@ -0,0 +1,58 @@
+# Contributor: tcely <tcely@users.noreply.github.com>
+# Maintainer:
+pkgname=botan
+_pkgname=Botan
+pkgver=2.9.0
+pkgrel=0
+pkgdesc="Crypto and TLS for C++11"
+url="https://botan.randombit.net/"
+arch="all"
+license="BSD-2-Clause"
+depends=""
+depends_dev="boost-dev bzip2-dev openssl-dev sqlite-dev xz-dev zlib-dev"
+makedepends="$depends_dev python2"
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://botan.randombit.net/releases/$_pkgname-$pkgver.tgz"
+builddir="$srcdir/$_pkgname-$pkgver"
+install=""
+
+# secfixes:
+# 2.9.0-r0:
+# - CVE-2018-20187
+# 2.7.0-r0:
+# - CVE-2018-12435
+# 2.6.0-r0:
+# - CVE-2018-9860
+# 2.5.0-r0:
+# - CVE-2018-9127
+
+build() {
+ cd "$builddir"
+
+ ./configure.py \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --with-boost \
+ --with-bzip2 \
+ --with-lzma \
+ --with-openmp \
+ --with-openssl \
+ --with-sqlite3 \
+ --with-zlib
+
+ make
+}
+
+check() {
+ cd "$builddir"
+ ./botan-test
+}
+
+package() {
+ cd "$builddir"
+
+ make DESTDIR="$pkgdir" install
+ rm -rf "$pkgdir"/usr/lib/python*
+}
+
+sha512sums="b88f3894a4a5b7b2fbff9be6eb0b774bf679a014bd2364811b7e63d4f323e22ca9ef916491afbc2cdf9db68727c1449fbeb6fd417e591560add0955517db3f65 Botan-2.9.0.tgz"