aboutsummaryrefslogtreecommitdiffstats
path: root/community/btrbk
diff options
context:
space:
mode:
authordai9ah <dai9ah@protonmail.com>2018-03-05 19:15:27 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-03-05 23:42:17 +0000
commitf884ba839e7e9187ca14e151b9ea1fd035f8e01e (patch)
tree458457d5038823d97b35e413e048b297de03970c /community/btrbk
parentb0a4a1b7045c584b8bf625545cbfa87c564c91af (diff)
downloadaports-f884ba839e7e9187ca14e151b9ea1fd035f8e01e.tar.bz2
aports-f884ba839e7e9187ca14e151b9ea1fd035f8e01e.tar.xz
community/btrbk: add simple check, install under '/usr/bin'
Diffstat (limited to 'community/btrbk')
-rw-r--r--community/btrbk/APKBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/community/btrbk/APKBUILD b/community/btrbk/APKBUILD
index 39ee259bb1..c31e307f5a 100644
--- a/community/btrbk/APKBUILD
+++ b/community/btrbk/APKBUILD
@@ -9,14 +9,18 @@ arch="noarch"
license="GPL-3.0-or-later"
depends="perl perl-date-calc btrfs-progs"
makedepends="asciidoc"
-options="!check"
subpackages="$pkgname-doc"
source="http://digint.ch/download/$pkgname/releases/$pkgname-$pkgver.tar.xz"
builddir="$srcdir"/$pkgname-$pkgver
+check() {
+ cd "$builddir"
+ ./btrbk -h > /dev/null
+}
+
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install
+ make DESTDIR="$pkgdir" BINDIR=/usr/bin" install
rm -rf "$pkgdir"/usr/lib # systemd scripts
}