aboutsummaryrefslogtreecommitdiffstats
path: root/community/ceph/APKBUILD
diff options
context:
space:
mode:
authorIggy Jackson <iggy@theiggy.com>2019-05-15 13:55:01 -0700
committerNatanael Copa <ncopa@alpinelinux.org>2019-09-11 06:58:58 +0000
commit7ea3d28dbdb191729bdbbff5ee0025cd78b98288 (patch)
tree4b63f342396106354aa661934d6e1531ce7bd3e4 /community/ceph/APKBUILD
parent07542ea0be8328b825507138e54fe228d5c6154a (diff)
downloadaports-7ea3d28dbdb191729bdbbff5ee0025cd78b98288.tar.bz2
aports-7ea3d28dbdb191729bdbbff5ee0025cd78b98288.tar.xz
community/ceph: Split ceph-mon into 3 packages
Split ceph-mon into smaller individual packages with a "virtual" package to pull them all in to maintain backwards compat. This makes it easier to run just the ceph-mon daemon without any other deps installed i.e. for containerized workloads.
Diffstat (limited to 'community/ceph/APKBUILD')
-rw-r--r--community/ceph/APKBUILD26
1 files changed, 22 insertions, 4 deletions
diff --git a/community/ceph/APKBUILD b/community/ceph/APKBUILD
index 451d7e3181..877cde7abc 100644
--- a/community/ceph/APKBUILD
+++ b/community/ceph/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: John Coyle <dx9err@gmail.com>
pkgname=ceph
pkgver=14.2.2
-pkgrel=0
+pkgrel=1
pkgdesc="Ceph is a distributed object store and file system"
pkgusers="ceph"
pkggroups="ceph"
@@ -96,6 +96,8 @@ subpackages="
$pkgname-mds
$pkgname-mgr
$pkgname-mon
+ $pkgname-mon-daemon:mon_daemon
+ $pkgname-mon-tools:mon_tools
$pkgname-fuse:ceph_fuse
$pkgname-osd
$pkgname-osd-daemon:osd_daemon
@@ -282,11 +284,27 @@ mds() {
}
mon() {
+ pkgdesc="Cluster monitor daemon virtual package for the Ceph distributed file system."
+ depends="ceph-base
+ $pkgname-mon-daemon=$pkgver-r$pkgrel
+ $pkgname-mon-tools=$pkgver-r$pkgrel"
+
+ mkdir -p "$subpkgdir"
+}
+
+mon_daemon() {
pkgdesc="Cluster monitor daemon for the Ceph distributed file system."
- depends="ceph-base"
+ depends=""
+
+ _pkg $_bindir ceph-mon
+ install -m 750 -o $_ceph_uid -g $_ceph_gid -d \
+ "$subpkgdir"$_localstatedir/lib/ceph/mon
+}
+
+mon_tools() {
+ pkgdesc="Cluster monitor tools for the Ceph distributed file system."
- _pkg $_bindir ceph-mon \
- ceph-monstore-tool
+ _pkg $_bindir ceph-monstore-tool
install -m 750 -o $_ceph_uid -g $_ceph_gid -d \
"$subpkgdir"$_localstatedir/lib/ceph/mon
}