aboutsummaryrefslogtreecommitdiffstats
path: root/community/ceph/APKBUILD
diff options
context:
space:
mode:
authorIggy Jackson <iggy@theiggy.com>2019-08-22 17:25:29 -0700
committerLeo <thinkabit.ukim@gmail.com>2019-09-23 02:41:15 -0300
commitdfcb0be619d5c0fcaf736caaede53876ac594432 (patch)
treeb9019b9f6f1863629f390c975be7e7d8429c5c86 /community/ceph/APKBUILD
parent58ebdb2b70120795ea428a46bd6a05f6e9b05165 (diff)
downloadaports-dfcb0be619d5c0fcaf736caaede53876ac594432.tar.bz2
aports-dfcb0be619d5c0fcaf736caaede53876ac594432.tar.xz
community/ceph: use $pkgname instead of ceph for subpackages
* Use $pkgname in place of the word ceph for some reason
Diffstat (limited to 'community/ceph/APKBUILD')
-rw-r--r--community/ceph/APKBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/community/ceph/APKBUILD b/community/ceph/APKBUILD
index a624b0135a..159d0fdfc9 100644
--- a/community/ceph/APKBUILD
+++ b/community/ceph/APKBUILD
@@ -226,8 +226,8 @@ user() {
base() {
pkgdesc="Base is the package that includes all the files shared amongst ceph servers"
depends="$_base_deps
- ceph-user=$pkgver-r$pkgrel
- ceph-common=$pkgver-r$pkgrel
+ $pkgname-user=$pkgver-r$pkgrel
+ $pkgname-common=$pkgver-r$pkgrel
librbd=$pkgver-r$pkgrel
librados=$pkgver-r$pkgrel
libcephfs=$pkgver-r$pkgrel
@@ -301,7 +301,7 @@ mds() {
mon() {
pkgdesc="Cluster monitor daemon virtual package for the Ceph distributed file system."
- depends="ceph-base
+ depends="$pkgname-base
$pkgname-mon-daemon=$pkgver-r$pkgrel
$pkgname-mon-tools=$pkgver-r$pkgrel"
@@ -310,7 +310,7 @@ mon() {
mon_daemon() {
pkgdesc="Cluster monitor daemon for the Ceph distributed file system."
- depends="ceph-user=$pkgver-r$pkgrel"
+ depends="$pkgname-user=$pkgver-r$pkgrel"
_pkg $_bindir ceph-mon
install -m 750 -o $_ceph_uid -g $_ceph_gid -d \
@@ -372,7 +372,7 @@ osd() {
osd_daemon() {
pkgdesc="Object storage daemon for the Ceph distributed file system."
- depends="$_osd_daemon_deps ceph-user=$pkgver-r$pkgrel"
+ depends="$_osd_daemon_deps $pkgname-user=$pkgver-r$pkgrel"
_pkg $_bindir ceph-osd
_pkg $_libexecdir/ceph ceph-osd-prestart.sh