aboutsummaryrefslogtreecommitdiffstats
path: root/community/ceph/APKBUILD
diff options
context:
space:
mode:
authorIggy Jackson <iggy@theiggy.com>2019-05-17 18:49:11 -0700
committerNatanael Copa <ncopa@alpinelinux.org>2019-09-11 06:58:58 +0000
commitf447dc4074622e90c15ab4bc9fb7752098d19b6b (patch)
tree64e782d0bf63a901fac3008fcee355ac9705f4e9 /community/ceph/APKBUILD
parent30eecb35b1cd4b9c27625f39bc956bc96e46f4ab (diff)
downloadaports-f447dc4074622e90c15ab4bc9fb7752098d19b6b.tar.bz2
aports-f447dc4074622e90c15ab4bc9fb7752098d19b6b.tar.xz
community/ceph: Move user create to separate pkg
Move user create to separate package that can be dep'ed by multiple other packages. This isn't strictly necessary, but is probably least surprising for users.
Diffstat (limited to 'community/ceph/APKBUILD')
-rw-r--r--community/ceph/APKBUILD19
1 files changed, 16 insertions, 3 deletions
diff --git a/community/ceph/APKBUILD b/community/ceph/APKBUILD
index 5bbc61ef4c..e246b0a1fa 100644
--- a/community/ceph/APKBUILD
+++ b/community/ceph/APKBUILD
@@ -99,6 +99,7 @@ subpackages="
$pkgname-mon-daemon:mon_daemon
$pkgname-mon-tools:mon_tools
$pkgname-fuse:ceph_fuse
+ $pkgname-openrc
$pkgname-osd
$pkgname-osd-daemon:osd_daemon
$pkgname-osd-tools:osd_tools
@@ -106,6 +107,7 @@ subpackages="
$pkgname-radosgw
$pkgname-bash-completion:bash_completion:noarch
$pkgname-dev
+ $pkgname-user
rbd-fuse:rbd_fuse
rbd-mirror:rbd_mirror
rbd-nbd:rbd_nbd
@@ -210,9 +212,21 @@ check() {
ctest
}
+# This subpackage is a little weird and a side effect of trying to keep
+# the daemon packages as small as possible. We might be able to roll this into
+# the base/common package later if we can slim those down or break them up in a
+# different way
+user() {
+ pkgdesc="Minimal package to create a user for other ceph packages."
+ depends=""
+ install="$pkgname-user.pre-install"
+ mkdir -p "$subpkgdir"
+}
+
base() {
pkgdesc="Base is the package that includes all the files shared amongst ceph servers"
depends="$_base_deps
+ ceph-user=$pkgver-r$pkgrel
ceph-common=$pkgver-r$pkgrel
librbd=$pkgver-r$pkgrel
librados=$pkgver-r$pkgrel
@@ -245,7 +259,6 @@ base() {
common() {
pkgdesc="Common utilities to mount and interact with a ceph storage cluster."
depends="py3-rados py3-rbd py3-cephfs"
- install="$pkgname-common.pre-install"
_pkg $_bindir ceph \
ceph-authtool \
@@ -297,7 +310,7 @@ mon() {
mon_daemon() {
pkgdesc="Cluster monitor daemon for the Ceph distributed file system."
- depends=""
+ depends="ceph-user=$pkgver-r$pkgrel"
_pkg $_bindir ceph-mon
install -m 750 -o $_ceph_uid -g $_ceph_gid -d \
@@ -359,7 +372,7 @@ osd() {
osd_daemon() {
pkgdesc="Object storage daemon for the Ceph distributed file system."
- depends="$_osd_daemon_deps"
+ depends="$_osd_daemon_deps ceph-user=$pkgver-r$pkgrel"
_pkg $_bindir ceph-osd
_pkg $_libexecdir/ceph ceph-osd-prestart.sh