aboutsummaryrefslogtreecommitdiffstats
path: root/community/certbot
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2019-12-15 10:13:18 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2019-12-15 10:13:21 +0000
commitf123c0b5edb213245ffe8084407de6b0633d6df5 (patch)
tree80530c0008e4b854a666bc076fb9e55c4d6822e6 /community/certbot
parent89abec428839f3ac2225ad97a42d099c2358a547 (diff)
downloadaports-f123c0b5edb213245ffe8084407de6b0633d6df5.tar.bz2
aports-f123c0b5edb213245ffe8084407de6b0633d6df5.tar.xz
community/certbot: upgrade to 1.0.0
Removed acme, apache and nginx subpackages. Now are standalone since no longer part of main certbot package
Diffstat (limited to 'community/certbot')
-rw-r--r--community/certbot/APKBUILD71
-rw-r--r--community/certbot/cerbot_py3_looseversion.patch8
2 files changed, 12 insertions, 67 deletions
diff --git a/community/certbot/APKBUILD b/community/certbot/APKBUILD
index 0756a3a165..4c8373b3e6 100644
--- a/community/certbot/APKBUILD
+++ b/community/certbot/APKBUILD
@@ -1,14 +1,14 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=certbot
-pkgver=0.40.1
+pkgver=1.0.0
pkgrel=0
pkgdesc="An ACME client that can update Apache/Nginx configurations"
url="https://github.com/certbot/certbot"
arch="noarch"
license="Apache"
depends="
- py3-acme=$pkgver-r$pkgrel
+ py3-acme
py3-configargparse
py3-configobj
py3-cryptography
@@ -25,77 +25,20 @@ depends="
"
checkdepends="py3-augeas"
replaces="letsencrypt"
-subpackages="py3-acme:acme $pkgname-nginx $pkgname-apache"
-source="certbot-$pkgver.tar.gz::https://github.com/certbot/certbot/archive/v$pkgver.tar.gz
+source="https://pypi.io/packages/source/c/certbot/certbot-${pkgver}.tar.gz
cerbot_py3_looseversion.patch"
build() {
- local i
- for i in . $subpackages; do
- cd "$builddir"/${i##*:}
- python3 setup.py build
- done
+ python3 setup.py build
}
check() {
- local i
- for i in . $subpackages; do
- cd "$builddir"/${i##*:}
- python3 setup.py check
- done
+ python3 setup.py check
}
package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-acme() {
- cd "$builddir"/acme
- pkgdesc="ACME protocol implementation for Python"
- depends="
- py3-setuptools
- py3-cryptography
- py3-josepy
- py3-mock
- py3-openssl
- py3-pyrfc3339
- py3-tz
- py3-requests
- py3-requests-toolbelt
- py3-six
- "
- python3 setup.py install --prefix=/usr --root="$subpkgdir"
-}
-
-nginx() {
- cd "$builddir"/certbot-nginx
- pkgdesc="nginx plugin for $pkgname"
- depends="
- certbot=$pkgver-r$pkgrel
- py3-acme=$pkgver-r$pkgrel
- py3-mock
- py3-openssl
- py3-setuptools
- py3-zope-interface
- py3-parsing
- "
- python3 setup.py install --prefix=/usr --root="$subpkgdir"
-}
-
-apache() {
- cd "$builddir"/certbot-apache
- pkgdesc="apache plugin for $pkgname"
- depends="
- certbot=$pkgver-r$pkgrel
- py3-acme=$pkgver-r$pkgrel
- py3-mock
- py3-augeas
- py3-setuptools
- py3-zope-component
- py3-zope-interface
- "
- python3 setup.py install --prefix=/usr --root="$subpkgdir"
-}
-
-sha512sums="e5517a20cf26efba850728b3f81db5d6c3c5570b0a1c8eeeec9d4a4401ac04bcf44c6a2f1c248bf6e0b1be4a21b54f6168ccd11dc766304805f13b4cb16336b3 certbot-0.40.1.tar.gz
-2886130eb5c28c3af3435107f2c8fce1c2cd8e1fbf1a49c11f8ba276b5748c26913748bbc4af10dca522a55e82bbae786f9a06d7c75efe94faf9afb0597f91b7 cerbot_py3_looseversion.patch"
+sha512sums="ab432f3986b28d88857a550016b21240f5af85f145e12c291c9b99060c22d1d313b1ea0000db132ae0297f238096b7754ce37d409e5c83d8d67564058c657307 certbot-1.0.0.tar.gz
+e03356f528551a3b885c2eb45f18358bd1fd628b0b1a780f12cb49e6f9f3b9b81e2449d9bea4f48ba368d5c0c7f183e9d32d9a094a6d828339382f4b4938b30a cerbot_py3_looseversion.patch"
diff --git a/community/certbot/cerbot_py3_looseversion.patch b/community/certbot/cerbot_py3_looseversion.patch
index 5a10fde67f..399dc5da84 100644
--- a/community/certbot/cerbot_py3_looseversion.patch
+++ b/community/certbot/cerbot_py3_looseversion.patch
@@ -1,6 +1,8 @@
+diff --git a/setup.py b/setup.py
+index c1bf914..2f4c9d4 100644
--- a/setup.py
+++ b/setup.py
-@@ -3,7 +3,7 @@
+@@ -3,7 +3,7 @@ import os
import re
import sys
@@ -9,10 +11,10 @@
from setuptools import find_packages, setup, __version__ as setuptools_version
from setuptools.command.test import test as TestCommand
-@@ -60,7 +60,7 @@
+@@ -60,7 +60,7 @@ install_requires = [
# So this dependency is not added for old Linux distributions with old setuptools,
# in order to allow these systems to build certbot from sources.
- pywin32_req = 'pywin32>=225' # do not forget to edit pywin32 dependency accordingly in windows-installer/construct.py
+ pywin32_req = 'pywin32>=227' # do not forget to edit pywin32 dependency accordingly in windows-installer/construct.py
-if StrictVersion(setuptools_version) >= StrictVersion('36.2'):
+if LooseVersion(setuptools_version) >= LooseVersion('36.2'):
install_requires.append(pywin32_req + " ; sys_platform == 'win32'")