aboutsummaryrefslogtreecommitdiffstats
path: root/community/certbot
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2019-08-08 08:51:38 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2019-08-08 08:51:38 +0000
commitf2df3c2fe845c28c37626d99200de820a48b4d9b (patch)
tree6ebb452eb2c236c365577803d96e15cf88cde5ba /community/certbot
parentbbd876ded56f4e40bdfb762e31b7eca6e5501d48 (diff)
downloadaports-f2df3c2fe845c28c37626d99200de820a48b4d9b.tar.bz2
aports-f2df3c2fe845c28c37626d99200de820a48b4d9b.tar.xz
community/certbot: upgrade to 0.37.0
Diffstat (limited to 'community/certbot')
-rw-r--r--community/certbot/APKBUILD8
-rw-r--r--community/certbot/remove-check-for-setuptools-version.patch25
2 files changed, 17 insertions, 16 deletions
diff --git a/community/certbot/APKBUILD b/community/certbot/APKBUILD
index 38016afc0e..b283bab561 100644
--- a/community/certbot/APKBUILD
+++ b/community/certbot/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=certbot
-pkgver=0.36.0
-pkgrel=1
+pkgver=0.37.0
+pkgrel=0
pkgdesc="An ACME client that can update Apache/Nginx configurations"
url="https://github.com/certbot/certbot"
arch="noarch"
@@ -97,5 +97,5 @@ apache() {
python3 setup.py install --prefix=/usr --root="$subpkgdir"
}
-sha512sums="f7fa8c6200a76b4fc4830865bf11fbba8bd73ea55e1236680181073952505c83b4650b43ccfc8e9b96caf47b85c43e47acf8db6d92134f7c279ebd954ab0ac92 certbot-0.36.0.tar.gz
-cc9647c9d1d6909e3d3df7adcb5816f814c4665ec54a5d0680b4a97d1599451db0fd192ff2e3a91c174ec2d8681fe0f62d7a3d40cc07081d058a6a6169f734a3 remove-check-for-setuptools-version.patch"
+sha512sums="3f2df5f591ba241719fe2e5e90c2b87e2d932d991d943eefbe00b9d76f7fb056d3b6026879511f591473c698b798e78645879f018a78e503b8a06280b036cb35 certbot-0.37.0.tar.gz
+eef4247230e27327b90b07489ff8774539624135f2196010fd0c188709da7f092afcb58d8690a48280e508f619bc580295eeb8d12364234d1933a35d31c4c924 remove-check-for-setuptools-version.patch"
diff --git a/community/certbot/remove-check-for-setuptools-version.patch b/community/certbot/remove-check-for-setuptools-version.patch
index 7d8d0711eb..4c74e07b03 100644
--- a/community/certbot/remove-check-for-setuptools-version.patch
+++ b/community/certbot/remove-check-for-setuptools-version.patch
@@ -1,21 +1,22 @@
diff --git a/setup.py b/setup.py
-index 84c27fc..97b0606 100644
+index 017b666..d5eafef 100644
--- a/setup.py
+++ b/setup.py
-@@ -58,11 +58,11 @@ install_requires = [
- # However environment markers are supported only with setuptools >= 36.2.
- # So this dependency is not added for old Linux distributions with old setuptools,
- # in order to allow these systems to build certbot from sources.
+@@ -53,17 +53,6 @@ install_requires = [
+ 'zope.interface',
+ ]
+
+-# Add pywin32 on Windows platforms to handle low-level system calls.
+-# This dependency needs to be added using environment markers to avoid its installation on Linux.
+-# However environment markers are supported only with setuptools >= 36.2.
+-# So this dependency is not added for old Linux distributions with old setuptools,
+-# in order to allow these systems to build certbot from sources.
-if StrictVersion(setuptools_version) >= StrictVersion('36.2'):
-- install_requires.append("pywin32 ; sys_platform == 'win32'")
+- install_requires.append("pywin32>=224 ; sys_platform == 'win32'")
-elif 'bdist_wheel' in sys.argv[1:]:
- raise RuntimeError('Error, you are trying to build certbot wheels using an old version '
- 'of setuptools. Version 36.2+ of setuptools is required.')
-+#if StrictVersion(setuptools_version) >= StrictVersion('36.2'):
-+# install_requires.append("pywin32 ; sys_platform == 'win32'")
-+#elif 'bdist_wheel' in sys.argv[1:]:
-+# raise RuntimeError('Error, you are trying to build certbot wheels using an old version '
-+# 'of setuptools. Version 36.2+ of setuptools is required.')
-
+-
dev_extras = [
'astroid==1.6.5',
+ 'coverage',