aboutsummaryrefslogtreecommitdiffstats
path: root/community/cloc/APKBUILD
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2017-04-02 15:52:37 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2017-04-03 08:42:38 +0200
commitba69a56a359c3ae03439487ea2f85525381d79fd (patch)
tree87c9add5a22858ae77d209ceaefe99db94784271 /community/cloc/APKBUILD
parent06bee5a224c344df0c1aa2865ea372ab2e5318ad (diff)
downloadaports-ba69a56a359c3ae03439487ea2f85525381d79fd.tar.bz2
aports-ba69a56a359c3ae03439487ea2f85525381d79fd.tar.xz
community/cloc: modernize abuild
Diffstat (limited to 'community/cloc/APKBUILD')
-rw-r--r--community/cloc/APKBUILD26
1 files changed, 15 insertions, 11 deletions
diff --git a/community/cloc/APKBUILD b/community/cloc/APKBUILD
index 2c1946c321..32db2c5142 100644
--- a/community/cloc/APKBUILD
+++ b/community/cloc/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
pkgname=cloc
pkgver=1.72
-pkgrel=0
+pkgrel=1
pkgdesc="Count lines of code"
url="https://github.com/AlDanial/cloc"
arch="noarch"
@@ -10,22 +10,26 @@ license="GPL2"
depends="perl perl-algorithm-diff perl-regexp-common"
makedepends=""
subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/AlDanial/$pkgname/archive/v$pkgver.tar.gz"
-builddir="$srcdir/$pkgname-$pkgver/Unix"
+source="https://github.com/AlDanial/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz
+ disable-submodule-tests.patch"
+builddir="$srcdir/$pkgname-$pkgver"
-build () {
- make -C "$builddir" || return 1
+build() {
+ make -C "$builddir"/Unix
+}
+
+check() {
+ make -C "$builddir"/Unix
}
package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"/Unix
+ make DESTDIR="$pkgdir" install
mkdir -p "$pkgdir"/usr/share/doc/$pkgname/
install -Dm644 NEWS README AUTHORS \
- "$pkgdir"/usr/share/doc/$pkgname/ || return 1
+ "$pkgdir"/usr/share/doc/$pkgname/
}
-md5sums="d0e8e19a03f198fc86df2f3d73e788ec cloc-1.72.tar.gz"
-sha256sums="2d2c57478b6c8b77d90d8b2aa278a3bd1f18251f5cf3cfeb017db2c27ad86af2 cloc-1.72.tar.gz"
-sha512sums="599ad5664eeb9ca4918e83e2cce5723c2546ad4a160f4a20f5537675c478d859f2f0bac03b271926df477943eb047a4711511a198a3ddc6a20dbc76c868d46e9 cloc-1.72.tar.gz"
+sha512sums="e83567fcc2703b6de761c44d3b85e4c176eaff9f35419a202bd4c00b5cc9160d39251deb762d57b40aacf4fe6322cf79877032ed29abec2a5f00c1abb8d44021 cloc-1.72.tar.gz
+0da21579aee7b073dcff93767289e2ae50dbde50fdfd4b5dc36264cc0aa52be1f42b80f18378e264eef5a0c81eb447013343247781bc571f78c226a5c28e93c2 disable-submodule-tests.patch"