aboutsummaryrefslogtreecommitdiffstats
path: root/community/cloudi
diff options
context:
space:
mode:
authorMichael Truog <mjtruog@protonmail.com>2019-12-14 15:55:59 -0800
committerLeo <thinkabit.ukim@gmail.com>2019-12-15 08:41:49 +0100
commit8f6ad9ab497dc3a6a37214ad681faa00666a947e (patch)
treef78cf5dc0c6a82ffe2d9753fde339b5850a1b6b7 /community/cloudi
parent49cef7dfff99db964a87c8c39021f799e7a8fafb (diff)
downloadaports-8f6ad9ab497dc3a6a37214ad681faa00666a947e.tar.bz2
aports-8f6ad9ab497dc3a6a37214ad681faa00666a947e.tar.xz
community/cloudi: Upgrade to 1.8.0
* erlang-otp-ocaml-compattibility.patch is no longer necessary * python-3.7.patch is no longer necessary
Diffstat (limited to 'community/cloudi')
-rw-r--r--community/cloudi/0005-Disable-tests-for-aports-buildservers.patch10
-rw-r--r--community/cloudi/APKBUILD24
-rw-r--r--community/cloudi/erlang-otp-ocaml-compattibility.patch21
-rw-r--r--community/cloudi/python-3.7.patch18
4 files changed, 15 insertions, 58 deletions
diff --git a/community/cloudi/0005-Disable-tests-for-aports-buildservers.patch b/community/cloudi/0005-Disable-tests-for-aports-buildservers.patch
index 51b5a22a5b..7287b95ba1 100644
--- a/community/cloudi/0005-Disable-tests-for-aports-buildservers.patch
+++ b/community/cloudi/0005-Disable-tests-for-aports-buildservers.patch
@@ -1,15 +1,15 @@
--- ./src/rebar_src_test.config.in
+++ ./src/rebar_src_test.config.in
-@@ -8,8 +8,6 @@
- {sub_dirs,
- ["lib/cloudi_core",
+@@ -9,8 +9,6 @@
+ "lib/cloudi_service_api_batch",
"lib/cloudi_service_api_requests",
+ "lib/cloudi_service_cron",
- "lib/cloudi_service_db_mysql",
- "lib/cloudi_service_db_pgsql",
"lib/cloudi_service_filesystem",
"lib/cloudi_service_http_client",
"lib/cloudi_service_http_cowboy1",
-@@ -18,9 +16,7 @@
+@@ -19,9 +17,7 @@
"lib/cloudi_service_map_reduce",
"lib/cloudi_service_monitoring",
"lib/cloudi_service_null",
@@ -18,4 +18,4 @@
- "lib/cloudi_service_quorum",
"lib/cloudi_service_request_rate",
"lib/cloudi_service_router",
- "lib/cloudi_service_tcp",
+ "lib/cloudi_service_shell",
diff --git a/community/cloudi/APKBUILD b/community/cloudi/APKBUILD
index ddb580e964..6d9e0b8186 100644
--- a/community/cloudi/APKBUILD
+++ b/community/cloudi/APKBUILD
@@ -28,8 +28,8 @@
# (shown below with the assignment of CLOUDI_PID_FILE).
pkgname=cloudi
-pkgver=1.7.5
-pkgrel=8
+pkgver=1.8.0
+pkgrel=0
pkgdesc="Cloud computing framework for efficient, scalable, and stable soft-realtime event processing."
url="https://cloudi.org/"
license="MIT"
@@ -72,28 +72,26 @@ makedepends="autoconf
ruby
"
subpackages="$pkgname-static $pkgname-openrc"
-source="https://osdn.net/dl/$pkgname/$pkgname-$pkgver.tar.gz
+source="https://osdn.net/dl/cloudi/cloudi-$pkgver.tar.gz
0005-Disable-tests-for-aports-buildservers.patch
- python-3.7.patch
- erlang-otp-ocaml-compattibility.patch
$pkgname.initd"
-builddir="$srcdir/cloudi-$pkgver"
# configure additional dependencies based on the package architecture
-CONFIGURE_ARGS=""
+
# Enable OCaml on the appropriate architectures
case "$CTARGET_ARCH" in
x86 | armhf | armv7)
;;
*)
makedepends="$makedepends ocaml"
- CONFIGURE_ARGS="$CONFIGURE_ARGS --enable-ocaml-support"
+ _configure_args="$_configure_args --enable-ocaml-support"
;;
esac
+# Enable Haskell on the appropriate architectures
case "$CTARGET_ARCH" in
x86_64)
makedepends="$makedepends ghc cabal zlib-dev"
- CONFIGURE_ARGS="$CONFIGURE_ARGS --enable-haskell-support"
+ _configure_args="$_configure_args --enable-haskell-support"
;;
esac
@@ -117,7 +115,7 @@ build() {
--build="$CBUILD" \
--with-cxx-backtrace \
--with-python-version=3 \
- --enable-go-support $CONFIGURE_ARGS
+ --enable-go-support $_configure_args
make
}
@@ -133,8 +131,6 @@ package() {
"$pkgdir"/etc/init.d/$pkgname
}
-sha512sums="6684f498b501b47f583c86bb949aec68db4f8f91dd57c352989b01792e871d7e3e3386e658d6b71791c2baf7fc618c67b4fd85487ff27a17ef6f495cad5f241f cloudi-1.7.5.tar.gz
-d831cc9672c12f27cf958975d72a3cb02ca21e78347f278a840679ab89479f795aba5ff0378731f276863fc5a3237d1bd0f861ccedc41e77321a19d726da8ca9 0005-Disable-tests-for-aports-buildservers.patch
-020e7c08867e2d84e75eeee74b72f1d79de481fb2affb815f6780d8ce9777dfda2aff71a5af4c066dce334b63b55f05706dfe751379479c086f6e573aa1b9ee0 python-3.7.patch
-4b03608893095df39181e004a88372ed6d2752166f4b2867e053e9c07ee0793cd8590d2720906a9ff093924766349b548b0e5439b129b09193b64f02645f6824 erlang-otp-ocaml-compattibility.patch
+sha512sums="53a99729fa37673cfcc7fb7e76e285ff7bd978a080a65d46259b53c6dd0854214ee91b0e93f090d6958045f7e1eb0b739fcfc13c86070780f518f48bd9732fc8 cloudi-1.8.0.tar.gz
+8b3c67ce0899b64b9f48da749864b95e3d9747383c1daabdad7e6230ebb815329ccbdc7f69a956590ddda0a32ff74d073f98bdc0b15d5dc4728dd11640835a6c 0005-Disable-tests-for-aports-buildservers.patch
053f860f656617012208a0e1909e43b2f8979d381a90d3fa5a745a9cf5021fe54556a641fef2badaa9955f2394d00e32183389cb9b501169dcbf8cbe4fbb0329 cloudi.initd"
diff --git a/community/cloudi/erlang-otp-ocaml-compattibility.patch b/community/cloudi/erlang-otp-ocaml-compattibility.patch
deleted file mode 100644
index 614f14daee..0000000000
--- a/community/cloudi/erlang-otp-ocaml-compattibility.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-From 479eef923b756fdcfea395d63e2383f18479ada0 Mon Sep 17 00:00:00 2001
-From: Michael Truog <mjtruog@protonmail.com>
-Date: Sat, 18 May 2019 19:36:17 -0700
-Subject: [PATCH] Add Erlang/OTP 23 compatibility. Add OCaml 4.08.0
- compatibility. Update the Erlang binary term format encoding implementations
- to support Erlang/OTP 23 with the programming languages Go, Haskell, Java,
- Javascript, OCaml, Perl, PHP, Python and Ruby. Update uuid.
-
-diff --git a/src/api/ocaml/cloudi.ml b/src/api/ocaml/cloudi.ml
-index 044396dd..c661af37 100644
---- a/src/api/ocaml/cloudi.ml
-+++ b/src/api/ocaml/cloudi.ml
-@@ -162,7 +162,7 @@ module Instance = struct
- let callbacks_remove api pattern =
- let key = api.prefix ^ pattern in
- let value = Hashtbl.find api.callbacks key in
-- let _ = Queue.pop value in
-+ let _f = Queue.pop value in
- if Queue.is_empty value then
- Hashtbl.remove api.callbacks key ;
- ()
diff --git a/community/cloudi/python-3.7.patch b/community/cloudi/python-3.7.patch
deleted file mode 100644
index 189a835131..0000000000
--- a/community/cloudi/python-3.7.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-based on https://github.com/CloudI/CloudI/commit/a7d593e3aa84b157e9c6c2d49fa072c8756d884a
-
-diff --git a/src/api/python/cloudi_py.cpp b/src/api/python/cloudi_py.cpp
-index ad3124f7..0e38c880 100644
---- a/src/api/python/cloudi_py.cpp
-+++ b/src/api/python/cloudi_py.cpp
-@@ -752,8 +752,9 @@ class callback : public CloudI::API::function_object_c
- {
- Py_ssize_t response_size_tmp = 0;
- #ifdef PYTHON_VERSION_3_3_COMPATIBLE
-- response = PyUnicode_AsUTF8AndSize(result,
-- &response_size_tmp);
-+ response =
-+ const_cast<char *>(PyUnicode_AsUTF8AndSize(
-+ result, &response_size_tmp));
- if (response == NULL)
- {
- PyErr_Print();