aboutsummaryrefslogtreecommitdiffstats
path: root/community/clsync
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2017-09-27 06:14:34 +0000
committerTimo Teräs <timo.teras@iki.fi>2017-09-27 06:14:49 +0000
commit03e91816c57d213790d88e5e9377c3c432a73dd2 (patch)
tree9efdd65455c8843d6ddd86b661589e1f0175ecdc /community/clsync
parent5cab4780ac8d20b7a03dd69455826d100b340b64 (diff)
downloadaports-03e91816c57d213790d88e5e9377c3c432a73dd2.tar.bz2
aports-03e91816c57d213790d88e5e9377c3c432a73dd2.tar.xz
community/clsync: musl supports pthread_setname_np now
Diffstat (limited to 'community/clsync')
-rw-r--r--community/clsync/APKBUILD8
-rw-r--r--community/clsync/pthread_setname_np.patch13
2 files changed, 3 insertions, 18 deletions
diff --git a/community/clsync/APKBUILD b/community/clsync/APKBUILD
index 0cfa0f3521..f5f1ae57fe 100644
--- a/community/clsync/APKBUILD
+++ b/community/clsync/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=clsync
pkgver=0.4.2
-pkgrel=0
+pkgrel=1
pkgdesc="File live sync daemon based on inotify"
url="https://github.com/xaionaro/clsync"
arch="x86 x86_64"
@@ -12,8 +12,7 @@ depends_dev="glib-dev fts-dev libcap-dev libexecinfo-dev linux-headers musl-dev"
makedepends="$depends_dev autoconf automake file libtool"
subpackages="$pkgname-doc $pkgname-dev"
source="$pkgname-$pkgver.tar.gz::https://github.com/xaionaro/$pkgname/archive/v$pkgver.tar.gz
- musl-fix.patch
- pthread_setname_np.patch"
+ musl-fix.patch"
builddir="$srcdir/$pkgname-$pkgver"
options="!check" # upstream does not provide tests
@@ -51,5 +50,4 @@ package() {
}
sha512sums="d14a2efc4bf58d9d5c7a3fe5634cacdd182cd7cd814b0e9ebd99024a7282b056d1f7ceeec6903666391c3572d599a18e205af818b098ed7768d5c0e0f4cd1200 clsync-0.4.2.tar.gz
-98e81408911731f6e203368094ea0e9eda312648eef8c5beec98b13c6ee43bccee59f0777805bea4d26cbe4e964d2ff95fe863be5be7750b50358d213f106542 musl-fix.patch
-da65cfb7182fa1509c77d7da43132c1f8b4911acb819d90aaab88c78d35167c85c0f23259bb78983fdab8217c43ba93b6b21267ab96c7fdf4723878a800fe414 pthread_setname_np.patch"
+98e81408911731f6e203368094ea0e9eda312648eef8c5beec98b13c6ee43bccee59f0777805bea4d26cbe4e964d2ff95fe863be5be7750b50358d213f106542 musl-fix.patch"
diff --git a/community/clsync/pthread_setname_np.patch b/community/clsync/pthread_setname_np.patch
deleted file mode 100644
index aab4dd4ef8..0000000000
--- a/community/clsync/pthread_setname_np.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-pthread_setname_np is a glibc extension not defined in POSIX
-and is not supported by musl libc.
---- a/privileged.c
-+++ b/privileged.c
-@@ -920,7 +920,7 @@
- # endif
- } else {
- register_blockthread();
-- pthread_setname_np(pthread_self(), "clsync-helper");
-+ //pthread_setname_np(pthread_self(), "clsync-helper");
- }
- cap_drop(ctx_p, ctx_p->caps);
-