aboutsummaryrefslogtreecommitdiffstats
path: root/community/cogl
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-04-08 19:36:17 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-04-08 23:57:19 +0000
commitaa54f509c7d7bb6c419f1a5666810409cb42c6e9 (patch)
tree092a238390de0c1648b33db807ef2fc920fa5c53 /community/cogl
parentb6a2cf9a9fe21b1d060039b1ee5dbf95bd727bf9 (diff)
downloadaports-aa54f509c7d7bb6c419f1a5666810409cb42c6e9.tar.bz2
aports-aa54f509c7d7bb6c419f1a5666810409cb42c6e9.tar.xz
community/cogl: move from main
Diffstat (limited to 'community/cogl')
-rw-r--r--community/cogl/17.patch62
-rw-r--r--community/cogl/APKBUILD66
2 files changed, 128 insertions, 0 deletions
diff --git a/community/cogl/17.patch b/community/cogl/17.patch
new file mode 100644
index 0000000000..e683ae442f
--- /dev/null
+++ b/community/cogl/17.patch
@@ -0,0 +1,62 @@
+Upstream: Yes, https://gitlab.gnome.org/GNOME/cogl/-/merge_requests/17
+
+From 9c4764224aded552fb855b1c2b85b26d2b894adf Mon Sep 17 00:00:00 2001
+From: Alexander Tsoy <alexander@tsoy.me>
+Date: Tue, 29 Oct 2019 18:17:51 +0300
+Subject: [PATCH] Fix building against libglvnd-provided EGL headers
+
+Add missing EGL/eglmesaext.h include. When building against mesa-provided
+headers, this header is included indirectly via EGL/eglext.h.
+
+Also fix typo COGL_EGL_INCLUDE -> COGL_EGL_INCLUDES
+---
+ configure.ac | 16 ++++++++++++++--
+ 1 file changed, 14 insertions(+), 2 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index da188edd..b0b0c94d 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -670,10 +670,15 @@ AS_IF([test "x$enable_gles1" = "xyes"],
+ AC_SUBST([COGL_EGL_INCLUDES])
+
+ AC_CHECK_HEADERS([EGL/eglext.h],
+- [COGL_EGL_INCLUDES="$COGL_EGL_INCLUDE
++ [COGL_EGL_INCLUDES="$COGL_EGL_INCLUDES
+ #include <EGL/eglext.h>"],
+ [],
+ [$COGL_EGL_INCLUDES])
++ AC_CHECK_HEADERS([EGL/eglmesaext.h],
++ [COGL_EGL_INCLUDES="$COGL_EGL_INCLUDES
++#include <EGL/eglmesaext.h>"],
++ [],
++ [$COGL_EGL_INCLUDES])
+
+ # Check for a GLES 1.x Common Profile library with/without EGL.
+ #
+@@ -1178,6 +1183,12 @@ AS_IF([test "x$NEED_EGL" = "xyes" && test "x$EGL_CHECKED" != "xyes"],
+ [],
+ [AC_MSG_ERROR([Unable to locate required EGL headers])],
+ [#include <EGL/egl.h>])
++ AC_CHECK_HEADERS(
++ [EGL/eglmesaext.h],
++ [],
++ [AC_MSG_ERROR([Unable to locate required EGL headers])],
++ [#include <EGL/egl.h>
++#include <EGL/eglext.h>])
+
+ AC_CHECK_LIB(EGL, [eglInitialize],
+ [COGL_EXTRA_LDFLAGS="$COGL_EXTRA_LDFLAGS -lEGL"],
+@@ -1188,7 +1199,8 @@ AS_IF([test "x$NEED_EGL" = "xyes" && test "x$EGL_CHECKED" != "xyes"],
+ )
+
+ COGL_EGL_INCLUDES="#include <EGL/egl.h>
+-#include <EGL/eglext.h>"
++#include <EGL/eglext.h>
++#include <EGL/eglmesaext.h>"
+ AC_SUBST([COGL_EGL_INCLUDES])
+ ])
+
+--
+2.24.1
+
diff --git a/community/cogl/APKBUILD b/community/cogl/APKBUILD
new file mode 100644
index 0000000000..8245fe3385
--- /dev/null
+++ b/community/cogl/APKBUILD
@@ -0,0 +1,66 @@
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=cogl
+pkgver=1.22.6
+pkgrel=0
+pkgdesc="An object oriented GL/GLES Abstraction/Utility Layer"
+options="!check" # All tests fail for unknown reasons
+url="https://gitlab.gnome.org/GNOME/cogl"
+arch="all"
+license="MIT"
+makedepends="
+ automake
+ autoconf
+ libtool
+ libxcomposite-dev
+ libxrandr-dev
+ mesa-dev
+ gdk-pixbuf-dev
+ wayland-dev
+ pango-dev
+ cairo-dev
+ gobject-introspection-dev
+ gtk-doc
+ "
+# gstreamer-dev
+# gst-plugins-base-dev
+# "
+subpackages="$pkgname-dev $pkgname-lang"
+source="https://download.gnome.org/sources/cogl/${pkgver%.*}/cogl-$pkgver.tar.xz
+ 17.patch"
+
+prepare() {
+ default_prepare
+
+ autoreconf -fi
+}
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --enable-gles2 \
+ --disable-gles1 \
+ --enable-kms-egl-platform \
+ --enable-gl \
+ --enable-gdk-pixbuf \
+ --enable-introspection \
+ --enable-cairo \
+ --enable-wayland-egl-platform \
+ --enable-wayland-egl-server
+ make -j1 # fails to link cogl-gst into itself otherwise...
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="b3475fa4fff3b6725f643b0d17d2de242fce1503cd83bd18031d98495501917bf5173152fb1aba7f2614fcf6553029fbb6f26bda5a497f5f12e2849ed301a483 cogl-1.22.6.tar.xz
+5320cfe16eaa419aac155d86f77826076b3dfe3a018d7173220c35ba2f1a4f15254bab7336229349aa25e708f0792132572d166de5745992a4e98f662b6df0fc 17.patch"