aboutsummaryrefslogtreecommitdiffstats
path: root/community/compton
diff options
context:
space:
mode:
authorScrumpyJack <scrumpyjack@st.ilet.to>2016-06-27 10:17:05 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2016-07-04 11:42:28 +0200
commit2ff62bbb9f7b2c82a826d7b159c1bc482aa8f0bd (patch)
tree97c60fb3221dfe78cd7ccfda5db6125c81d5f676 /community/compton
parent00e8ff605f1c4f6386596f35f2a5287ff9b8bc55 (diff)
downloadaports-2ff62bbb9f7b2c82a826d7b159c1bc482aa8f0bd.tar.bz2
aports-2ff62bbb9f7b2c82a826d7b159c1bc482aa8f0bd.tar.xz
testing/[various]: move packages to community
Moves the packages listed below from the testing to the community repository after successfully testing of said packages. asciinema at calcurse cmus compton cpio dvd+rw-tools fortune fvwm geary h2o heirloom-mailx leafpad nedit nmh rover tor torsocks urlview vdesk w3m wbar xcalc xclock xeyes xkill
Diffstat (limited to 'community/compton')
-rw-r--r--community/compton/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/community/compton/APKBUILD b/community/compton/APKBUILD
new file mode 100644
index 0000000000..b4f2cc6bf5
--- /dev/null
+++ b/community/compton/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=compton
+pkgver=0.1_beta2
+pkgrel=0
+pkgdesc="X Compositor (a fork of xcompmgr-dana)"
+url="https://github.com/chjj/compton"
+arch="all"
+license="MIT"
+depends=""
+depends_dev="libx11-dev libxcomposite-dev libxinerama-dev libxdamage-dev \
+ libconfig-dev pcre-dev libxrandr-dev dbus-dev libdrm-dev mesa-dev"
+makedepends="$depends_dev asciidoc"
+install=""
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/chjj/$pkgname/archive/v$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+ sed -i "s:\(COMPTON_VERSION ?= \)git.*:\1v${pkgver}:" Makefile
+}
+
+build() {
+ cd "$_builddir"
+ make PREFIX=/usr
+}
+
+package() {
+ cd "$_builddir"
+ make PREFIX="$pkgdir"/usr install
+ install -D -m644 "LICENSE" "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ install -D -m644 "compton.sample.conf" "$pkgdir/etc/xdg/compton.conf.example"
+}
+
+md5sums="fed786fa5ee9eb89df02291f2cc6e04d compton-0.1_beta2.tar.gz"
+sha256sums="7b9cd52a57326116fb5db3f5f89b7d50e17715252d9fd79b70b45ace30a6b009 compton-0.1_beta2.tar.gz"
+sha512sums="c3a019d90e32559d44e3a4969bcc15a15837db9c9519ce8cc70b1bd3d0cb16d29449f68cc2f6a8d834569c9620ec6533ab85c1586da957c69b1ae341d9584535 compton-0.1_beta2.tar.gz"