aboutsummaryrefslogtreecommitdiffstats
path: root/community/connman
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-02-24 15:21:40 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-02-25 23:12:25 -0300
commitb2368e987805f160f3eb002a0573adba0ab70263 (patch)
tree7e9288643e844def1c2fea14801b1a6649fcf059 /community/connman
parent5dec7ba229a6ad3a70a4a8ebd755f47dba6d03dd (diff)
downloadaports-b2368e987805f160f3eb002a0573adba0ab70263.tar.bz2
aports-b2368e987805f160f3eb002a0573adba0ab70263.tar.xz
community/connman: transition into supervise-daemon
Diffstat (limited to 'community/connman')
-rw-r--r--community/connman/APKBUILD6
-rw-r--r--community/connman/connman.initd20
2 files changed, 11 insertions, 15 deletions
diff --git a/community/connman/APKBUILD b/community/connman/APKBUILD
index 5f3bd11863..05dd3884b6 100644
--- a/community/connman/APKBUILD
+++ b/community/connman/APKBUILD
@@ -2,8 +2,8 @@
# Contributor: Valery Kartel <valery.kartel@gmail.com>
pkgname=connman
pkgver=1.38
-pkgrel=1
-pkgdesc="A daemon for managing internet connections"
+pkgrel=2
+pkgdesc="Daemon for managing internet connections"
url="https://01.org/connman"
arch="all"
license="GPL-2.0-only"
@@ -46,4 +46,4 @@ package() {
sha512sums="9c8f77c4dd62763ccb9ea5cc5d285a8a1c51bb09a82eafc73246231557a4f627ae1e5e4a9df5e104457390ebba643349d7d67800a4ee4c17c6dceff192afe8d4 connman-1.38.tar.xz
122b48fc9e25354e25ba3a3e0864bdd84da84457fed94aeea726bcb189b2f05f2cc361ae15f44af5c49bcee572e91e4c0488ef3b0bc79d20f6efe15853fb6b3a libresolv.patch
-42b45d44f5eed966ba003683fcb54ffb4e9a0331599ff1c8e5e64c4c06b42d380c3852b7c73881a1be1eaca887906cac9aede1f5579e8e139fdf90ca8d7adf15 connman.initd"
+b0676714b3952f38d50f3707c3ec72269902dd07f3cefc412c2720d91d02c9537f2823eb4ed5359650eaa64b9132cddba3abc15fd68542ff0870de653e023ed8 connman.initd"
diff --git a/community/connman/connman.initd b/community/connman/connman.initd
index 1728694274..610aabf4ce 100644
--- a/community/connman/connman.initd
+++ b/community/connman/connman.initd
@@ -1,20 +1,16 @@
#!/sbin/openrc-run
+supervisor=supervise-daemon
+
+name="Network Management Daemon"
+description="Daemon for managing internet connections"
+
+: ${cfgfile:=/etc/connman/main.conf}
-description="Connection Manager"
-cfgfile=/etc/connman/main.conf
-pidfile=/run/connman/connman.pid
command=/usr/sbin/connmand
-command_args="$command_args -n -c $cfgfile"
-command_background="yes"
+command_args="$command_args -c $cfgfile"
+command_args_foreground="--nodaemon"
depend() {
need dbus
provide net
}
-
-start_pre() {
- ebegin
- checkpath --directory ${pidfile%/*}
- ln -sf ${pidfile%/*}/resolv.conf /etc/
- eend $?
-}