aboutsummaryrefslogtreecommitdiffstats
path: root/community/coreshot
diff options
context:
space:
mode:
authorrahmanshaber <rahmanshaber@yahoo.com>2019-09-24 13:08:15 +0800
committerRasmus Thomsen <oss@cogitri.dev>2019-10-06 11:41:13 +0200
commitb68242ff327f9be9f4ab55b1a8feb5ed9b65588c (patch)
treecf22d3c1370c236f2c14091b6a8d29f3a89398c3 /community/coreshot
parentb4faba3fde66e171fa9343bb9dd810669b01e1f1 (diff)
downloadaports-b68242ff327f9be9f4ab55b1a8feb5ed9b65588c.tar.bz2
aports-b68242ff327f9be9f4ab55b1a8feb5ed9b65588c.tar.xz
community/coreshot: move from testing
Diffstat (limited to 'community/coreshot')
-rw-r--r--community/coreshot/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/community/coreshot/APKBUILD b/community/coreshot/APKBUILD
new file mode 100644
index 0000000000..f54c7139be
--- /dev/null
+++ b/community/coreshot/APKBUILD
@@ -0,0 +1,24 @@
+# Contributor: rahmanshaber <rahmanshaber@yahoo.com>
+# Maintainer: rahmanshaber <rahmanshaber@yahoo.com>
+pkgname=coreshot
+pkgver=2.7.0
+pkgrel=0
+pkgdesc="A screen capture utility from the CoreApps family."
+arch="all"
+url="https://gitlab.com/cubocore"
+license="GPL-3.0-or-later"
+depends="qt5-qtsvg"
+makedepends="qt5-qtbase-dev libcprime-dev qt5-qtx11extras-dev"
+source="$pkgname-$pkgver.tar.gz::https://gitlab.com/cubocore/$pkgname/-/archive/v$pkgver/$pkgname-v$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-v$pkgver"
+options="!check"
+
+build() {
+ qmake-qt5
+ make
+}
+
+package() {
+ INSTALL_ROOT="$pkgdir" make install
+}
+sha512sums="72127fc1c066078ac537f3d7f14518196ec4bba21729618377636e6648817dd28c9bc9b9734431f6a925d0e93d90b0091028ceaa969aeba80bfa1f8e3be77dde coreshot-2.7.0.tar.gz"