aboutsummaryrefslogtreecommitdiffstats
path: root/community/crystal
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-08-13 13:31:56 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-08-13 13:56:59 +0200
commit49dc71f68e91de4dd1ca94ec71a4b9d39289a6ec (patch)
tree32e609a40967610aee0c53707b5bc0819c96474c /community/crystal
parentaa6d1b69a612262a48f656c477212ee5e586c44c (diff)
downloadaports-49dc71f68e91de4dd1ca94ec71a4b9d39289a6ec.tar.bz2
aports-49dc71f68e91de4dd1ca94ec71a4b9d39289a6ec.tar.xz
community/crystal: upgrade to 0.26.0
Diffstat (limited to 'community/crystal')
-rw-r--r--community/crystal/APKBUILD8
-rw-r--r--community/crystal/specs-tempdir-separate-helper.patch46
-rw-r--r--community/crystal/tests-libressl.patch29
3 files changed, 33 insertions, 50 deletions
diff --git a/community/crystal/APKBUILD b/community/crystal/APKBUILD
index 17599c2a57..acda357124 100644
--- a/community/crystal/APKBUILD
+++ b/community/crystal/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=crystal
-pkgver=0.25.1
+pkgver=0.26.0
pkgrel=0
_bootver=0.25.0
_llvmver=5
@@ -23,7 +23,7 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/crystal-lang/$pkgname/archiv
disable-specs-using-GB2312-encoding.patch
fix-spec-time-location.patch
libressl.patch
- specs-tempdir-separate-helper.patch
+ tests-libressl.patch
"
builddir="$srcdir/$pkgname-$pkgver"
@@ -120,11 +120,11 @@ zshcomp() {
"$subpkgdir"/usr/share/zsh/site-functions/_$pkgname
}
-sha512sums="b4b79985f0d47d56e2c22b74ac593ea8d21cc21c8e247e7043b6604c0a16906f1b8a9531c8902018f6fab35810177920eae26d3ada6874581e45713f69c9e8fb crystal-0.25.1.tar.gz
+sha512sums="45a62a2496d477cd72666e98b36bdcbfff958a8f5f0e71f04101f2ba72fc87117d53c8c098a72edb55e9be192b68b73529d5f76e4c660033332ed6e88a372519 crystal-0.26.0.tar.gz
b443520d994355f849e18d5432dc136f6e403eb77a432a53e3d38e5a050a7547632bbe7a99a3a4c193f91fdf2240a1629acd516291d16c3bbfa14a9ec47435b2 crystal-0.25.0-x86_64-alpine-linux-musl.tar.gz
43b058e94f990e853f2ade5bf234aaea4547176172beff8ed372c5158ec8bb59c3925e0bb3bf7c2e4024193bcd48652faebba3ce08c5f0e25425ca073a66adb0 crystal-0.25.0-aarch64-alpine-linux-musl.tar.gz
dec4ed7abfd215eec825bed97b1e40bf3aa8bd959a4ec7153ea1bc51d409d892ebec19ddb0372e3a543e74c7018aca0c1f3cf956fa1d95efb946c8c3417c8749 paxmark.patch
269976fbc990dde075769e651c9fac6e7e0b39681e55cbd067c6d2a790c58a096bdc9981f62ae69b5217623025ba768daa63bc5316bd8ddd18192d88839aedcb disable-specs-using-GB2312-encoding.patch
518f06dd191e43e4052c0f8c4963d31dfc7ed3b414d1bb2e7a82265af13853f85380b5507ef3c5a5a25f6091d7173d5322f379e354666eec4165264dd502e70b fix-spec-time-location.patch
31fd94f07edb83eb6ff43dd20f99a52e3c28dc0bf67f7e0b5c473c40d455febfbd0cdf9fe1fe599dbf080fd4c05a2a2d9ad8745f9effc8dfb565e19fa0e49509 libressl.patch
-78df92a5f9df00f5cbad1d6643148fee4724e1e07a08c366ebce6c837c7b3bba19ff69a1c78d072fe24b04f68f92bc464d557601116342120143651aa4e854a9 specs-tempdir-separate-helper.patch"
+35764190eb4df353057c771935c6b6588cddb3a164e624e3a07371c78e49f4dc938fd1296fdb048c08c482b5066b56f6d0b5eab5f48fdba80b01d2cf6e0ad24e tests-libressl.patch"
diff --git a/community/crystal/specs-tempdir-separate-helper.patch b/community/crystal/specs-tempdir-separate-helper.patch
deleted file mode 100644
index 9d07c0f8e6..0000000000
--- a/community/crystal/specs-tempdir-separate-helper.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-From 5f4c3697641654959a313a0332fbba59334f8ca3 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Johannes=20M=C3=BCller?= <straightshoota@gmail.com>
-Date: Mon, 2 Jul 2018 12:39:25 +0200
-Subject: [PATCH] Fix: Rename datapath helper to compiler_datapath for compiler specs
-
-Patch-Source: https://github.com/crystal-lang/crystal/pull/6312
-See-Also: https://github.com/crystal-lang/crystal/pull/5951#issuecomment-400986673
----
- spec/compiler/compiler_spec.cr | 4 ++--
- spec/compiler/spec_helper.cr | 2 +-
- 2 files changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/spec/compiler/compiler_spec.cr b/spec/compiler/compiler_spec.cr
-index 7fdbca20db..426a5324e0 100644
---- a/spec/compiler/compiler_spec.cr
-+++ b/spec/compiler/compiler_spec.cr
-@@ -4,7 +4,7 @@ require "./spec_helper"
- describe "Compiler" do
- it "compiles a file" do
- with_tempfile "compiler_spec_output" do |path|
-- Crystal::Command.run ["build", datapath("compiler_sample"), "-o", path]
-+ Crystal::Command.run ["build", compiler_datapath("compiler_sample"), "-o", path]
-
- File.exists?(path).should be_true
-
-@@ -13,7 +13,7 @@ describe "Compiler" do
- end
-
- it "runs subcommand in preference to a filename " do
-- Dir.cd datapath do
-+ Dir.cd compiler_datapath do
- with_tempfile "compiler_spec_output" do |path|
- Crystal::Command.run ["build", "compiler_sample", "-o", path]
-
-diff --git a/spec/compiler/spec_helper.cr b/spec/compiler/spec_helper.cr
-index 536691a5ad..8a7e40b314 100644
---- a/spec/compiler/spec_helper.cr
-+++ b/spec/compiler/spec_helper.cr
-@@ -1,6 +1,6 @@
- require "../spec_helper"
- require "../support/tempfile"
-
--def datapath(*components)
-+def compiler_datapath(*components)
- File.join("spec", "compiler", "data", *components)
- end
diff --git a/community/crystal/tests-libressl.patch b/community/crystal/tests-libressl.patch
new file mode 100644
index 0000000000..9513c122c5
--- /dev/null
+++ b/community/crystal/tests-libressl.patch
@@ -0,0 +1,29 @@
+Hacks needed to make tests pass on LibreSSL.
+
+--- a/spec/std/openssl/ssl/context_spec.cr
++++ b/spec/std/openssl/ssl/context_spec.cr
+@@ -194,13 +194,13 @@
+ expect_raises(ArgumentError, "missing private key") do
+ OpenSSL::SSL::Context::Client.from_hash({} of String => String)
+ end
+- expect_raises(OpenSSL::Error, "SSL_CTX_use_PrivateKey_file: error:02001002:system library:fopen:No such file or directory") do
++ expect_raises(OpenSSL::Error, "SSL_CTX_use_PrivateKey_file: error:02FFF002:system library:func(4095):No such file or directory") do
+ OpenSSL::SSL::Context::Client.from_hash({"key" => "foo"})
+ end
+ expect_raises(ArgumentError, "missing certificate") do
+ OpenSSL::SSL::Context::Client.from_hash({"key" => private_key})
+ end
+- expect_raises(OpenSSL::Error, "SSL_CTX_use_certificate_chain_file: error:02001002:system library:fopen:No such file or directory") do
++ expect_raises(OpenSSL::Error, "SSL_CTX_use_certificate_chain_file: error:02FFF002:system library:func(4095):No such file or directory") do
+ OpenSSL::SSL::Context::Client.from_hash({"key" => private_key, "cert" => "foo"})
+ end
+ expect_raises(ArgumentError, "Invalid SSL context: missing CA certificate") do
+@@ -212,7 +212,7 @@
+ expect_raises(ArgumentError, "Invalid SSL context: missing CA certificate") do
+ OpenSSL::SSL::Context::Client.from_hash({"key" => private_key, "cert" => certificate, "verify_mode" => "peer"})
+ end
+- expect_raises(OpenSSL::Error, "SSL_CTX_load_verify_locations: error:02001002:system library:fopen:No such file or directory") do
++ expect_raises(OpenSSL::Error, "SSL_CTX_load_verify_locations: error:02FFF002:system library:func(4095):No such file or directory") do
+ OpenSSL::SSL::Context::Client.from_hash({"key" => private_key, "cert" => certificate, "ca" => "foo"})
+ end
+ end